Beacon not longer detectable after failed update


after trying to update beacon OS to A2.2.0 (whicht stuck at 10% and then failed) one beacon is no longer detectable with your iOS App (latest Version, iOS 8).

The App now only shows the two other beacons (not updated) but the updated one doesn't appear in Radar or List any longer. Other Apps (eg. BLE Finder) shows three estimotes. The Beacon doesn't show up as 'Unsupported beacons' in Radar/List.

Any idea how i can get the beacon back to work?

Hi Heiko,

Sorry for the problem. To workaround it would it be possible for you to download the Examples project from our GitHub repo (, run it on your phone and use the Update Firmware Demo to resume the firmware update process? You'll need to be a member of Apple's iOS Developer Program to run the app on your device. If you're not, let me know and we'll try to find a different solution.

Note that in order to authorize the firmware update you'll also need to provide your App ID and App Token to the Examples app -- it's the "Authorize" button in the top-right hand corner of the main screen. Simply type in your ID and Token into the two fields and click "Back". You can find your ID and Token on, in the "Account Settings" section. UPDATE: In the Examples bundled with SDK 2.2 and later, you need to put your App ID and App Token directly into the Examples' source code—see ESTAppDelegate.m. It was super-inconvenient to type them manually into the app anyway (:

Let me know if it helps.

Hi Agnes,

Thanks for your help. I have tested the Examples project on my iPhone using the Values from "SDK App ID" and "SDK App Token" as credentials (changed line 23 in ESTAppDelegate.m) but always get an Connection error saying "You are not authorized to access this beacon." when i select a beacon. In fact i get this error message for every beacon, not only the one with the failed OS update. These beacons are listed under the "Your beacons" Section.

And there is no "Authorize" button in the Examples App. I am missing something?

We are seeing similar issues too with 2.2.1..the only way the connection seems to succeed is through the ESTIMOTE App..In our case, connect does not seem to perform callbacks as it used to.

Heiko, I have added the following to the ESTCloudAuthVC.m:
" - (void)viewWillDisappear:(BOOL)animated {
self.appIdField.text = @"Your app ID";
self.appTokenField.text =@"Your app Toke";

[ESTBeaconManager setupAppID:self.appField.text andAppToken:self.appTokenField.text];
It worked for me. For sure there is a more elegant way.


same problem!

So started the example on my iPhone and it is connecting to the broken one but now stuck in "downloading 0%" and nothing more...

Any new idea?


I am having the same issue. The firmware state of the beacon is ESTBeaconFirmwareStateBoot. This beacon does not appear in the beacon list in the latest version of the Estimote iOS APP, presumably because it is stuck in the boot mode and only available via CoreBluetooth scanning (see ESTBeacon.h in the library).

Hey guys—I updated Agnieszka's answer above. In the Examples bundled with SDK 2.2 and later, you need to put your App ID and App Token directly into the Examples' source code—see ESTAppDelegate.m. It was super-inconvenient to type them manually into the app anyway (:

@Erik, this is exactly the case. When firmware update fails (e.g. because the battery died or Bluetooth connection got dropped), the beacon enters a so-called "boot state" (as opposed to the fully functional "app state"). What you need to do then is, discover it via Core Bluetooth scan (see our SDK reference for a list of Core Location and Core Bluetooth scans) and re-initiate the firmware update. Conveniently, you can do this via our Examples app, instead of writing all the code yourself.


I put my ID and the Token directly into the source code. The Example App can find the beacon but then nothing is going on. Stops at the state "downloading".

Any idea?


@Piotr, Agnes wrote this in the initial answer to this thread (filling in the app id and app token). But it's still not working. And in fact i have now lost a second estimote so please fix your app so we can use them again.

The Estimote App (from iTunes) does'nt list the failed estimotes and your Example app lists them but is not able to update them so i see no way to get any estimote back to life.

Hi Joachim,

I remember we had a similar bug some time ago in the SDK, but we have fixed it since. Could you make sure to try with the latest version of the SDK and the Examples app? You'll find it on

I am using the SDK from commit "7c742261f086ca88db9b0b923a81350295b1a203" so I think that should be the most recent one. I am getting the same behavior as @Heiko in the iOS app, and I have put the ID and token directly in the source like @Joachim and am still experiencing the same problem.

Hey guys,

I can confirm we have a regression in the current version of the SDK, which results in the firmware update getting stuck at the "downloading" phase.

We're working to address that—in the meantime, you can use the SDK v. 2.1.5 to update your beacons' firmware:

Piotr, you made my day


Piotr, this worked for me as well.

Thank you!

Hi Piotr, thanks for your help.

But i got some strange effects now:
The estimote which i could not find in the Estimote App (from app store) will be listed in the example app (2.1.5) but i am not able to update the firmware because it allways says "Connection Error", "Device disconnected".
When i try to update the firmware for the two other estimotes it states "Up to date!" but there is still A2.1 installed, which is not up to date i think.

So it's not yet working for me and i have still one estimote unresponsible and two others which i could not update to A2.2.

What else can i try?

I am working on OS X 10.10.1 with XCode 6.1.1 and iOS 8.1.1 if thats helpful.



I tried the update of the Estimote app that was released yesterday, hoping it could revive the estimote which is still unresponsible but that one is still not showing up in the app. And guess what's happend while i was trying to update another estimote to ESTIMOTE OS A2.2.0 - update stuck at 10%, becomes red and boom, failed! Again! So now i have two broken estimotes and only one to work with.

See, i totally like the design and the features of the estimotes but what i not understand is why it is so hard to fix this bug? I really hope you could provide a working solution.

Heiko—really sorry about this! Could you try downloading SDK v. 2.1.5 ( and following the steps Aga described in the very first post in this thread? This should "revive" the beacon.

If you can't see the beacon in the Examples app, then most likely the battery's dead. Ping us at and we'll assist you with battery replacement.

Hi Piotr, i tried that yesterday without success.

Here is what i did:
- i provided the "App SDK Access"-credentials under "Account Settings" (namely "SDK App ID" and "SDK App Token" to the app.
- checked if authorizon works by accessing the "Temperature Demo" with the one beacon still responsible (there is only one estimote listed here!) which is working and i am authorized now.
- trying to update firmware using "Update Firmware Demo" (all estimotes listed here!) and selecting one of the not responding estimotes. This gives me this message "Connection error" "Device disconnected".

That's the output from Xcode:
2014-11-27 11:37:17.595 Examples[36989:1781806] Something went wrong. Beacon connection Did Fail. Error: Error Domain=EstimoteDomain Code=404 "Device disconnected" UserInfo=0x170274e40 {NSLocalizedDescription=Device disconnected}

So the not responding estimotes are not out of battery but i am either not able to reset or update them (ever again?).

Hey Heiko—a few ideas that come to mind:

  • make sure the beacon is right next to the phone
  • try in a less radio-wave noisy environment (far from other beacons or access points)
  • restart the phone, Bluetooth stack has a rare tendency to crash
  • "restart" the beacon itself by taking the battery out for 30 seconds and putting it back again