Beacon undetectable in Estimote App, iOS-SDK Example app and bluetooth scanner

I tried updating my new beacons to v3.0.1 using the Android Estimote app. I tried one beacon to start with and this stopped at 94% for 15 minutes at least. I turned off bluetooth as the app appeared to have hung. This triggered the app to prompt a “Failed update”. I couldn’t update the same beacon or see it even in the Android app.

I started the iOS Estimote app and selected Devices. Immediately I am showna message about an unsupported beacon and that I should update it. I decide to do this and it appeared to be successful, at least until I shut down the app and tried to list the devices again.

I can now no longer see the “updated” beacon in any app. I’ve tried both the iOS and Android Estimote apps, the iOS-SDK Examples app and I have even tried a simple bluetooth scanner. Nothing shows the beacon at all.

I did manage to update the other 2 beacons I have using only the iOS Estimote app. These are perfectly visible in the iOS app, and occasionally (subject for another issue I think) in the Android app.

I doubt it is battery as other posts may have indicated. These are brand new beacons and I’m pretty sure their indicated battery life was 2+ years.

Is there a way of resetting the devices in some way?

Well this is strange. I’ve left the beacons and devices alone for an hour and now I can find all 3 beacons using bluetooth scan and iOS Estimote app. What would have caused me to not see it before? Do the beacons do some kind of self-reset after a period of time?

When the update failed, the beacon entered a so-called “boot state”—think, when updating the operating system of a PC fails, and you end up with basic BIOS/UEFI. Estimote Beacons in the boot state lack most of their functionality, with the most prominent one remaining is “updating” the firmware back to the fully functional state.

Strange thing is, beacons in the boot state should still be discoverable by the Android app, where you can resume the firmware update. Not sure why this hasn’t happened for you—maybe it’s somehow connected with your other beacons appearing in the Android app only occasionally. What Android device are we talking about?

Anyway, in the iOS app, beacons in the boost state are discovered as “unsupported beacons,” and can have their firmware update automatically resumed—which seems to have worked for you. Once completed, the beacon should be immediately visible again—not sure why this hasn’t happened for you too.

We definitely will investigate—thanks for writing all of this up. Glad that the beacon is back to life at least, even if the experience was far from perfect. Sorry about that!