Update firmware stickers

Hi everyone,
I read here https://community.estimote.com/hc/en-us/articles/204096676-How-can-I-adjust-stickers-settings- that I need to update the firmware of the stickers in order to adjust the settings. And this can only be done using the iOS SDK (not even using the Estimote app, unlike for the beacon).
The problem is that I didn’t find anything in the SDK, probably it’s my bad.

Can anyone help me? Because for my project I really need to change the settings.

UPDATE: I found a demo for updating the firmware of the sticker. It was in the Beacon folder, not in the Nearable as I expected… I still have to try it though.

Yep, we’ll be reorganizing our examples shortly in the future to make things less confusing (:

As for the firmware update, that:

  1. you need to have the stickers assigned to your Estimote Account (i.e., showing up on https://cloud.estimote.com/#/nearables)

  2. you need to put your app ID and app token here:


    (if you don’t yet have these, you can generate them on https://cloud.estimote.com/#/apps/add/your-own-app)

  3. you need to be shaking the stickers in order for the SDK to be able to connect to it

1 Like

Thank you for the quick reply!

I have a few other questions, why is it possible to update the firmware from iOS SDK but not from the Estimote app? And when the support will arrive also on Android?

We’re in the middle of updating the iOS app with that. We usually first add things to our SDK, and then our app team takes the SDK and adds the appropriate support to the app.

Our roadmap for Android is fully booked till the end of the year, so we likely (and sadly) won’t be able to add the appropriate support for Android until early next year. (Which sounds a bit dramatic, but well, it’s only 1.5 months till 2016. :wink:)

Hi heypiotr,
I followed your steps to update the firmware, but it didn’t work. I’ll be more specific, the iPhone where I ran the demo app recognizes the stickers, but it doesn’t start the update (it keeps saying “connecting” and then an error message comes out).

Do you have any idea why?

You need to keep waving the sicker until connected. It usually connects on the first try for me, but sometimes I need to retry a few times.

I tried doing as you said and in one case the update stopped at 10%. On the second try on another sticker the updating process stopped at 99%. Both stickers are no more detectable by the firmware update demo and from the estimote app.

How can we recover these “damaged” stickers? And why the update failed both times?

We stopped trying to update the other stickers because we were afraid of damaging the others too.

Thanks for all the help!

Stickers have a backup copy of their previous firmware, so that when update fails, the sticker should simply revert to the old firmware, and still work just fine. Maybe the battery got loose or something? Can you try gently pressing on the top of the sticker, waving it, and see if it shows up in the app then?

99% is actually fine—the way we implemented it in the Examples, it never actually reaches 100%, just stops at 99% and when the label up top switches from “connected” to “disconnected,” that’s when firmware update is complete.

The sticker that finished the update process was detectable for a while but right now no more. Before it said Operating System “Unknown”, while in the others showed the info and also the Transmit power changed from -12dBm to 0 by itself.
The one that stopped at 10% it was never detected again.

So at the moment both of them are not detectable.

What could be the problem (and the solution)?