Firmware update not working

Trying to update firmware, gets stuck on "downloading" with progress stuck at 0%. Progress never increases and downloading status never changes. Further, the beacons don't get updated.

Using iOS 7.1 iPhone 4s & iOS 8 iPhone 5s
Estimote App v2.4
Beacons Firmware A1.9 Hardware D3.2 (these were from a dev preview kit)

Hey all - happy to report that this problem has been fixed in SDK 2.1.5.

Note that this thread is about firmware update issues when performed via our SDK. If you're having troubles updating the firmware via the Estimote app, ping me at piotr [at] - thanks!

Hi Jeff,

Did you try updating through Estimote SDK? You can find it on GitHub:


Yep, using the SDK has the same result... Connected -> Verified -> Downloading but Update progress never moves past 0% and beacon isn't updated.

Hi Jeff,

Reported this to our devlopers. They'll investigate the issue. Stay tuned, will keep you in the loop!


i am facing the same Issue any updates from estimote or it very from beacon to beacon as well.

Hi Harpeet,

What version of the app and iOS are you using?


we are working with ios 7.1.2 but we have tried out on ios 7.1.1 as well ,

we are using the Estimote Sdk provided on Github also tried the latest beta version i received on the mail

Hi Wojtek,
We are still waiting for your reply. Unable to update firmware.


The Cloud demo app (I assume that's what you received via mail) does not support firmware update. Please download our latest (2.5) app from iTunes and try updating with that one.

Let me know if it helps.


Using iOS 7.1.2, iPhone 5s, Estimote SDK 2.1.0-2-gc34012e I've been stuck on "value == 0, description == Downloading, error == (null)
" for 15 minutes now. Suggestions? Solutions?

Hey guys,

This is a bug in our SDK (2.0.0, 2.0.1 and 2.1.0 are affected) that we're aware of and are already working on fixing it. Stay tuned for a new version of the SDK pretty soon!

In the meantime, you can perform firmware update using the Estimote app, as it is unaffected by this bug.

Similar problem here (iPhone 5, iOS 7, Estimote app 2.6)
App prompts to "Put the beacon on your phone to start the update process.". Done that, then nothing happens.
Any suggestions?

Hi Robin,

Did you try killing the app entirely and launching it again?

@Eric: Sorry for the delay! Does the problem persist with the current SDK?



Have not tried since your post about it not working in SDK. I do know that I was able to use the Estimote App (from app store not the examples app in SDK) to upgrade all my beacons.

Was waiting for a post about it "working in current SDK". Will try soon and let you know. Is there new firmware available? If not, can I downgrade? if not, I can't confirm/deny until firmware update is available, as I stated I've upgraded all my beacons to latest firmware.


Hi Eric,

There is no new firmware, but we have new SDK available, which fixes the bug:


Hi Wojtek,
Yes i tried killing the app completely and restarting it. I even turned by phone off and on again. The iBeacon is on firmware A1.9. The app presents me with the option to update to A2.1. But when i place the iBeacon on the phone as indicated in the 'Beacon update' screen nothing happens. In fact nothing happens for quite a long time ;)

I have not tried the SDK. I am using the App from the App store.


Hi Robin,

Which app are you using? Did you try with the latest one: 2.6?


yes, i am using the latest iOS version: 2.6

Got it. Can you try updating with the SDK?