Two out of three beacons not detected

I'm working on an iOS app that detects beacons, picks the closest one and connects to it as soon as it's < 0.2 units/meters from the iOS device.

This has up until today-ish worked well. Now, all of a sudden(?), only one of my three beacons (all from Estimote) is detected -- regardless of whether it's the one closest to the iOS device or not.

Beacon X and Beacon Y are placed 0.5 meters away from the device. Beacon Z is 5 meters away. beacon Z is the only one detected.

Any idea what might be wrong?

Code for detecting and selecting the closest beacon:

Sorry for the late reply.

If you cannot detect Beacons at all, on any device, and the UUID is still at its default value, the most likely issue is that battery has died. Try replacing it with a new CR2450 coin battery. If you have any doubts or are not sure how to do it, shoot me an email: wojtek[at]estimote.

@Max: in your case, it might also be a bug affecting iOS Bluetooth connectivity (reported to Apple already). Please try rebooting your device and try again.


Hi Max,

Did you change the UUID of the other 2 Beacons? Are you able to detect them? Let me know.


Hi Wojtek,

I have not changed the UUID of any of the beacons. Can still not detect them.

iOS: 7.1

I know it's not a lot of information to work with, but I'm not sure what else to provide.

Same issue here. I also have not changed UUID or any other settings.

Hasan, did your beacons stop "working" at the same time? Do you know if they were ever detected by a unit using iOS 7.1?

I believe they were at one point. I am testing right now on multiple devices, both Android (HTC One and Nexus 5) as well as an iPhone 5, iPhone 5S, and iPad Retina. They beacons are not detected by any of these devices, and I have tried using 3rd party apps on both iOS and Android. They do not detect the beacons either.

Also tested on an iPad Retina running iOS 7.0.4 and not 7.1. Same problem.

Thanks for sharing, Hasan. How many beacons do you have? How many are not detected?

I had the same problem too. On arrival only 2 beacons worked and since a few days zero beacons did anything.
I ordered some new batteries and replaced them and everything is working fine. Maybe you need to reconsider the 2 years estimation?

Hi Roeland,

Really sorry for the issue! Can you drop me a line: wojtek[at]estimote?