Beacon is not detected by both iOS and Android app

My Beacon was working fine for the past few days and gives accurate proximity for both android and ios app.
But suddenly its not being detected by either apps. Can someone tell me the reason why it is not being detected?

Hi Nico,

Please check your inbox.

For others who might experience a situation like above, please mail me directly at ula(at) We have to investigate every case separately to know what can cause such behaviour, that's why there can't be one universal answer.

Hi there,

Did you try changing the UUID? If you've changed the UUID value, a Beacon will not be detected by Estimote app any more. This article might also prove useful in that case:


I have the same problem, the Estimote iOS app does not see any of my iBeacons but BLExplr sees all three. I have no memory of trying to change any UUID or so, have not had time to start playing around with these, but just realised IFTT has iBeacon support so wanted to test that out a bit, but the beacons are not seen there either.

Hi Karl-Petter,

Using iOS 7.1? If yes, then try rebooting your iPhone. There's a known bug in the iOS 7.1 Bluetooth stack and we're still waiting for Apple to issue a fix.


Rebooting the iPhone worked for me. Thanks

Hi, I have the same issue, on both Android and iOS. I have 3 beacons and lately only one is recognized (the green one). The other 2 are not recognized anymore, I tried to reboot my phones but no success. Which could be the problem? Thanks

Hi Laura,

Please check your inbox. I need some more information to help you with this.

Hi Ula,

i have the same problem as Laura. None of my beacons are recognized by your app or alternative apps.
I am waiting for your email.

Hi Markus,

Please, check your inbox. My message should already be waiting for you.

Hi Ula,
I am facing the above mentioned difficulty as well. Can you please share the answer or guide me to any documentation regarding the issue?


Hi Raeid,

Please check your inbox for a message from me.

Hi Ula,

I have the exact same problem as all others. My beacons do not appear in any app that can detect them. in the past it worked fine. Rebooting the device didn't help for me.


I worked Estimote beacon Sample application .Before 3 months Every thing is working fine .Now i Build the application agin but unfortunately It was not connecting the Beacon now ...How can i solve this issue .


Have you used our latest SDK version?
If yes, please write to me with the messages you get: ola at Thanks!

I just updated my phone to 7.1.2 to see how much better the new version would work but instead it does not see any of me iBeacons :( I tried to reboot the phone, which used to help before but not this time. Any ideas what might be wrong?

Hi Karl-Petter,

Are you sure it's not the battery? Check if tou can find the beacon with a 3rd party app like BLExplr for example. If not, then the battery has probably died. Shoot me an email ( if you need any tips on replacing it.


Before 3 months my beacons was working fine .Now i even with sample applciation not able to detect beacon. Can you please help ?

Hi Muthu,

It might be a battery issue. Please drop me a line to with your order number :)


I have the same problem, the Estimote iOS app does not see any of my iBeacons but BLExplr sees all three. I am using my correct same Estimote cloud credentials to login to my Estimote iOS app on my iPhone. My Estimote beacons show up in my cloud account display. Please advise what to do to fix. Thank you.