Problem with firmware update


Hello guys,

I am working on a Beacon project.

I try to update my beacon firmware cause I think it may be so outdated. Somehow, my beacon’s firmware is A1.9 and at the “Firmware Update” field, it say it up-to-date. There may be some problem. Can I have some advises from your team please?

My hardware revision is D3.3


I have a similar problem with an D3.3 beacon. It’s running A2.1, but the Estimote app reports that “This beacon is up to date”.

I’ve seen other threads on this forum where people have experienced issues like this, and someone from Estimote has helped them out… @heypiotr, can you help us out here?

Alternately, you can send an email with the issue.


i have same problem. With official estimote app from iOS i can’t update the firmware but some settings return an error where it says i have to update the device. (now it’s running A2.2, version D3.4)
Instead with Android app I can’t find any device in radar.
The packages were taken last year.
Some help on how i can proceed?


@macserv, @ddalto, can you private-message me the identifers of the beacons you’re trying to update? I’ll look into that. (To send a private message, click on my avatar and there’s a “message” button there.)