I can't register Google App : Beacon Tools


#1

Hi all I enable the Developer Access and as well EddyStone UID using Estimote App. Beacon Tools shows the Beacon but cant connect. the Error Message is : Fail to connect. do you need to push on the beacon?


Eddystone Configuration Service Unavailable
#2

I’m having this exact issue right now. I’ve read documentation for 2 hours now, the only thing I can think it might be is security permissions - you need to give Google authorised access to Estimote. To do this, follow steps 1 & 2 of http://developer.estimote.com/eddystone/eid-setup/

I’m just guessing that this is the issue though. I’ve just submitted my info, so hopefully I’ll find out soon if that’s the reason.


#3

Did you figure this out?


#4

I followed steps 1 and 2. Then they say email them to add the authorization. Cant do anything untill then. Does anyone know how long this takes? What if I have multiple beacons? Will I have to do it for each beacon?


#5

Am also searching for how to register estimote beacons in beacon tools app by google for using it in nearby messages api…! no improvements here also tools app shows error message told by OP


#6

I have contacted Estimote team and they replied with the solution for registering the estimote beacons, It works I have tested…!

In order to register the beacon with Google’s Beacon Tools, you’ll need to disable all of the packets on the beacon (including Eddystone packets), then turn on the Eddystone Configuration Service. After that, you should see the beacon in the Beacon Tools app in the Unregistered section.
You will need to provide a key to register the beacon through the app. It’s 00000000000000000000000000000000, and you may change it later, once the beacon’s registered.


#7

Hello Arun,

please could you be more specific about how to disable the all the packets, i am digging throu the Estimote cloud settings but i am unable to find this setting “Eddystone configuration Service” is nowhere to be found. Would help me a lot since i am unable to add a estimote beacon via Beacon Tool…

Thanks


#8

first of all select the eddystone UID,URL,TLM,EID,Telemetry,ibeacon…etc enabled settings to Off (click on the name in left hand side and make enabled option as off)

then enable eddyston configuration service that you can see in the screenshot…! thats all :wink:


#9

Aha! great Thanks!!!


#10

Sorry, but I’ve followed all the instructions and can’t get Eddystone Configuration Service turned on. I have all advertisements turned off. Anywhere there is an on/off choice, off is selected. Every instance of interval is set to 100. Still getting the turn off advertisements message. Beacon Firmware is 4.13.2

HELP???


#11

Within the app and Estimote Cloud settings menu, I dont see any Eddystone Configuration Service toggle. Am I missing something?


#12

Do you happen to have Proximity Beacons by any chance? Proximity Beacons currently don’t support Eddystone Configuration Service. If you want to register them with Google, you’ll need to use their API, instead of the Beacon Tools app. I’ve just uploaded some documentation about this to our Developer Portal:

https://developer.estimote.com/eddystone/google-proximity-beacon-api/


#13

I’m trying to register an estimote location beacon with Google Beacon Tools.
I edited the configuration at cloud.estimote, turned OFF all of the packets on the beacon (including Eddystone packets), then turned on the Eddystone Configuration Services and synchronized the beacon with the Estimote App.

Then, I TRIED to register the beacon in Google’s Beacon Tools App, however, now the beacon is not showing up in the Beacons Near Me list. It’s only when I turn on iBeacon packets, does the beacon show up on the list, HOWEVER, Eddystone Configuration Services cannot be enabled when the iBeacon is enabled.

How do I get around this issue?


#14

Even when you turn off all the packets, there’s one packet that Estimote Beacons always broadcast and that cannot be disabled: the Connection packet. And with ECS enabled, you should be able to use that to connect to the beacon in Beacon Tools, it’ll show up as an “unknown” configurable beacon:


#15

Hi,for me that code does not work, its there any other to try? for unlocking?


#16

For Estimote Beacons, it’s always all zeroes. Do you have an original Estimote Beacon (there’s a lot of knock-offs out there)? Did the beacon have a previous owner that maybe changed the code?