How to use Google Beacon Tools to manage my beacons ?


#1

Hello,

I just bought a pack of Beacon Location.

I would like to use Google Beacon Tools to manage them.

So I followed these instructions:

Unfortunately, the platform keeps showing me this error :

All advertisers must be disabled first before you can enable Eddystone Configuration Service. Keep in mind Eddystone Configuration Service requires use of third party configuration tools. It does not support configuration in Estimote Cloud and SDK.

Everything is turned off so I don’t understand what’s happening.
How can I resolve this issue ?

Thank you!


#2

Can you message me the identifier of your beacon? I’ll take a look.


#3

Thank you for your help Piotr now it works :slight_smile:

In case other people face the same issue here are some steps to get it working:

The issue was that Estimote Monitoring wasn’t properly disabled even though it shows as disabled.

Launch Estimote app to enable monitoring service.
Wait for a few seconds.
Then disable it again.
Turn on Eddystone Configuration Service (ECS).
Save, the error message has gone.
Kill Google Beacon Tools app if it was already open.
Relaunch Google Beacon Tools app.
Start scanning: surprise, your beacon is here.
Then use the key 32x0 to register.
Start playing!


#4

Thanks for the write-up @Mickael_MALOLEPSY. To shine some more light on this, basically, there’s an issue where if you disable Estimote Location packet in Estimote Cloud, it current doesn’t completely disable Estimote Monitoring/Estimote Indoor Location broadcasting—which prevents you from enabling ECS, even though it looks like all the packets are disabled.

The workaround for now is to disable the packets with the Estimote iOS or Android app, and not Estimote Cloud.

We hope to address that in the near future!


#5

Hello i am having the same issue regarding the Eddystone Configuration Service. Keeps showing me error message even though all packets are disabled. Please let me know if there is something else that needs to be done.


#6

Did you try the workaround I posted above?

The workaround for now is to disable the packets with the Estimote iOS or Android app, and not Estimote Cloud.

If you already disabled all the packets in the Cloud, go to the Estimote app, re-enable the Estimote Monitoring packet, then disable it again.


#7

Yes I’ve tried with the workaround you posted but had no luck. I’ve already enabled/disabled packets multiple times over cloud and app but message keeps showing up.


#8

:ok_hand:, thanks for giving it a shot. Can you message me the identifier of the beacon? I’ll take a look.


#9

@heypiotr I’m having the same issue with our beacons. Is there any solution for this?


#10

This should do it:

Go to your beacon in Estimote iOS/Android app, enable Estimote Monitoring, click “save/back” and wait till it saves/syncs to the beacon. Then repeat and disable Estimote Monitoring.


#11

I also have the same problem and follow the indications step by step and still the same error keeps coming up.


#12

Hi Heypiotr, I have followed your comments on getting BEACON Tools to connect to Estimote beacons. I have followed all instruction turning everything off, double checking cloud dasboard, connecting with Esimote app to apply setting. STILL beacon not connecting to beacon tools. I have killed beacon tools app and restarted, still nothing. CAN’T do anything, if i can’t register the beacons.

here is the beacon ID if you can help? 6cd1edff7710842a3b13b73d1cbb4214


#13

I can see that beacon still doesn’t have Estimote Monitoring fully disabled. It has a proper pending change to disable whatever remains, but that change hasn’t been synced to the beacon yet. Did you use the iOS or Android app to connect to the beacon to apply the settings? I think there used to be a problem in the Android app where it wouldn’t sync that exact setting, but I think it’s been fixed since, are you on the latest version of the app?


#14

Hii… My Beacon device is not connected in proximity range. And, if it connects then immediately it disconnects. What to do now? Mobdro How to solve this error???


#15

Yes I have latest version of Android app and I do sync to apply changed. It often does not update the cloud. How can we manage beacon fleet if your tools don’t work?

Michael Korson
myCoupongenie
248-761-1648


#16

I see everything is synced now and you have Eddystone Configuration Service enabled, is Beacon Tools working for you now? Are you using the iOS or Android Beacon Tools?


#17

Nope, can’t get estimote beacon to show up in beacon tools. Everything off - Eddystone Configuration Service ON.

6cd1edff7710842a3b13b73d1cbb4214 will not show up in beacon tools app. Support checked the backend and said it is configured properly and it WON’T pull into the beacon tools app.

THIS should not be this difficult. What is occurring???


#18

Are you using the iOS or Android Beacon Tools? I just tested on my own Proximity Beacon J1.6, and the iOS Beacon Tools app, and it worked for me.

Have you tried contacting Google’s support about it? If your beacon is configured properly now, but their app still doesn’t detect it, maybe they’ll know better how to diagnose/troubleshoot that, or what the problem could be.


#19

I am using android, and I have location beacons, not the proximity beacons which are supposed to do proximity also.


#20

Yea, Location Beacons or Proximity Beacons shouldn’t matter here.

I tried the Android Beacon Tools now, and I’m also having trouble. The beacon showed up once for me, and I even managed to connect, but then I couldn’t unlock the beacon, it’d just fail and go back to prompting me for the unlock code each time. So I restarted the app and tried again, and now I can’t see the beacon on the list anymore. (This is on Nexus 5X, which arguably is known to have a pretty problematic Bluetooth stack.)

In the meantime, the iOS Beacon Tools app keeps detecting the beacon, connects immediately, and unlocks just fine.


BTW, from what I see, it’s actually possible to use Beacon Tools to register a beacon in Google’s Cloud without having to provision it/use Eddystone Configuration Service. I enabled an Eddystone-UID packet on my other Estimote Beacon via Estimote app, went to iOS Beacon Tools, found it on the list, added a Description to it, and it now shows up on my Google Beacon Dashboard.

(I’m 99% sure it used to be the case that you had to use ECS with Beacon Tools in the past, otherwise the “Registration” box wouldn’t even show up. I guess they changed that, and I applaud that change :P)

So if you’re just trying to get your beacon registered in Google’s cloud, it might be easier to do it this way. (i.e., keep using Estimote tools to configure the beacon, only use the Beacon Tools for registration)