Error Alert : Claim Failed due to Bluetooth Problem

Full error:
“Claim failed due to Bluetooth problem. Make sure your device is close to the beacon and try again.”

iPhone 6
iOS 9.1
Estimote vs 2.16

MAC: e429bc436638
MAC: c44a6560202f
MAC: c6ecce286b99
MAC: e4478f288f3d
The 5th one is not even detected by the app, so I don’t know how to inform you of it’s identity.

There are 5 of my 30 beacons I ordered that cannot be claimed. I can find all 30 on my cloud account but between the 4 I can find and attempt to claim, and the 5th that I cannot even discover on the app, I’m becoming concerned of faulty beacons!

I ran into problems after completeing firmware upgrades for the other 25 beacons. These were the ones that gave me problems during the upgrade process.

I’ve tried re-installing the estimote app, but to no avail. Now I cannot even see the MAC addresses.

Any ideas on how I can regain access and update these beacons?

You’re beacons have likely desynced, i.e., they have a different UUID/major/minor in our cloud records, and different one physically being broadcast by the beacon. So to the Estimote app, it seems like you’re trying to connect to some completely different beacon, which you don’t own. Claim also fails because of that, albeit with a bit misleading error message.

The easiest way to bring them back in sync is: edit the 4 beacons on (i.e., queue up some pending changes), can be anything, e.g., change the interval by 1 ms. Then open the Estimote app, and wait for it to apply the changes. In the process of applying the changes, the “cloud” UUID+major+minor will be written to the beacon, and then it’s back in sync.

As for the one beacon that’s not being detected at all—you can try pressing firmly on top of the enclosure, to see if it’s maybe a battery that got loose in its holder? If this doesn’t help, you can cut the enclosure, pull the PCB out, then pull the battery out and put it back in (i.e., forcing a reboot). And finally, you could try changing the battery. Also, shoot us an email to, and reference this thread, and we’ll send you replacement enclosure, for the one you had to destroy; or a replacement beacon, if nothing mentioned above helps. Sorry for all the trouble!

Also, as we’re trying to pinpoint why exactly beacons desync in the first place—can you let us know how you changed the UUIDs of your beacons? Was it via + app, or in-app only?

I have been making changes exclusively in

The attempt to change the broadcast time and have the beacon sync via the app also failed. There are still changes awaiting completion. Additionally, the iPhone app does not recognize the color of the beacon, MAC address, or any other details it saw prior to my re-installing the app.

The beacon that cannot be detected also is still inert. I pressed firmly to replace the batter and will take it apart now.

Any other ideas?

The color and MAC are fetched from Estimote Cloud, so it the beacon is desynced, this will fail too.

Does the beacon has a cloud icon on top, on the list screen? Could you post a screenshot? Thanks!

Follow up:

I’ve managed to connect, update, and apparently fix the 4 beacons I had issues with by using an android device with the estimote app. The 5th still is unresponsive after dismantling the shell and toying with the battery. A new one is on its way.

Good to know, thanks! Yes, our Android app discovers beacons by their MAC addresses, so it’s immune to the desynchronization issues.