Can't edit data of beacons reassigned to me

I have 6 beacons just assigned to me. When I see the beacon and select it in the Estimote app on iOS it briefly flashes “Authenticating as” (with my real email address) and then a Claim button appears. However this beacon already shows in the web dashboard as my beacon. If I try to claim anyhow I get the error “Claim failed due to server error. Please check the internet connection and try again.” My internet connection is just fine, this is not the problem. There is some issue between the Estimote client app and the server beacon registration data. How do I fix this so I can edit my beacons??

Hi there,

Can you check if the IDs (UUID, Major, Minor) on the physical beacons match those visibe in cloud dashboard?


You mention “reassigned to me” in the title, does this mean the beacons were recently transferred from another account to your own? After the “authenticating as …” disappears, does anything else show up in its place? Is it all the beacons or just one? Can you shoot me a private message with your Estimote Cloud login and the MAC address of the beacon you’re trying to connect to?

Sorry for a lot of :grey_question:, should help with troubleshooting though (:

The IDs did in fact match. Interestingly it’s all working now. Maybe there is some kind of delay (cache update?) from the time the beacons are assigned to the time the iPhone app can see them.

Ha, interesting, thanks for sharing. We’ll look into that!

Hello, i seem to have the same problem.
I have two DEV Kits, so total of 6 beacons.
I changed the emailadress of my account and after that i managed to add three beacons (out of one set i guess) to my account. I also was able to change the UUID. That took come time, but that’s the delay the other person in this conversation was talking about i guess. Now my problem: with the three other beacons i keep on getting the error ‘Claim failed due to server error. Please check the internet connection and try again’. The internet connection is ok; i tried via WiFi and 4G via my phone via the app. I do see the beacons in the list Devices > List. The UUID for all the three beacons is the same by the way. Mac Address is different ofcourse. Major and minor are also different.

What to do? My account is connected to email by the way.


Remco de Jong


I’ve replied to your email. Problem solved :smile: