Devices show up in Estimote app Devices tab but not in Notify Demo or Distance Demo

It looks like my iPhone is able to get into a mode where beacons are ignored or not seen. I first noticed it when debugging my own app so I went back to the Estimote iOS app itself to make sure everything was working. The devices all show up in the Devices tab (radar and list view), but when I switch to one of the demo modes, nothing at all shows up under “Select Beacon”.

I have tried the following (nothing works):

  1. rebooting the iPhone
  2. reinstalling the Estimote app
  3. logging out and back into Estimote app

Remote management still seems to work.
I am using my own UUID, not the default one (maybe the app only works with the default UUID?)

It possibly has something to do with the custom UUID. On iOS, when you’re logged out, our app doesn’t know what UUID to scan for, and so it only scans for the default one. But if you’re logged in to your Estimote Account, it should also be scanning for your own UUIDs.

On the Devices tab, we scan for Connectivity packets instead of the iBeacon packets, so we usually detect all beacons regardless of their UUID, or even the fact if they broadcast iBeacon at all.

(Note that what I described applies to our next-gen beacons w/ firmware 4.x. It works a bit differently for our legacy Proximity Beacons, i.e., hardware revision “D” and firmware 3.x.)

It is if my phone is no longer able to figure out the location access rights…

I’m staring at the Location Services screen and it clearly says “Allow Location Access While Using the App”, and yet…

2016-09-21 09:19:57.684442 WhizzMacSProximityCont1R3[907:298048] Ranging failed for region: B9407F30-F5F8-466E-AFF9-25556B57FE6D:2:1. Make sure that Bluetooth and Location Services are on, and that Location Services are allowed for this app. Beacons require a Bluetooth Low Energy compatible device: Note that the iOS simulator doesn’t support Bluetooth at all. The error was: Error Domain=ESTBeaconManagerErrorDomain Code=2 “Insufficient Location Services authorization. Ranging will pause until appropriate authorization is granted.” UserInfo={NSLocalizedDescription=Insufficient Location Services authorization. Ranging will pause until appropriate authorization is granted.,

New error surfaced after I restarted the phone:

2016-09-21 09:47:28.691977 WhizzMacSProximityCont1R3[252:5830] Couldn’t fetch data from Estimote Cloud for beacon B9407F30-F5F8-466E-AFF9-25556B57FE6D:2:2, will use default values instead. Double-check if the app ID and app token provided in the AppDelegate are correct, and if the beacon with such ID is assigned to your Estimote Account. The error was: Error Domain=ESTRequestBaseErrorDomain Code=404 “The requested resource does not exist.” UserInfo={NSLocalizedDescription=The requested resource does not exist., NSLocalizedRecoverySuggestion=Verify if requested resource exists.}

I built the app again and checked the new app ID and the beacons all seem to match. It does look like being unable to reach the estimote cloud could be the problem. I will change my credentials and try that.

That didn’t work. At first the Estimote Devices tab reported beacon IDs without names. When I logged in with the new credentials it reports all my beacon names correctly, so I assume the Estimote app is correctly connecting to the cloud.

Now when I click the Devices tab I see everything, but when I click on Notify or Distance Demo and try to find a beacon I get nothing, same as before.

So, after fiddling with things for a while I conclude the following…

The resource that is missing is the beacon name. I changed all beacons back to default UUID and used the Estimote app to sync to cloud on each beacon. Everything looks fine.

Now when I run your app I see the name for one beacon and a null string for the other two beacons even though everything looks fine in Estimote Cloud.

Is something that you can check at the Estimote end?

It could come down to needing an update for your example app that uses the new ESTRequestGetBeaconsDetails API

Thanks for a thorough report! We’re looking into it.