Unable to change settings on Beacon

So I’m trying to do some prototyping with a couple of my Location Beacons but the Dark-to-Sleep and Flip-to-Sleep options don’t seem to do anything.

I’ve tried updating Flip to Sleep in the Estimote app (Which the beacon says is on) but when I flip it over, the beacon still broadcasts.

I’ve also tried setting Dark to Sleep and Flip to Sleep via cloud.estimote.com but when I save these changes, they don’t seem to apply to the beacons when I connect to them via the app to pull down the cloud settings. The App does say that they are Synced via Cloud but cloud.estimote.com still states that these two beacons have pending settings.


Thanks for taking the time to report that. We’re aware of a bug in the SDK that prevents conditional broadcasting settings (flip to sleep, dark to sleep, and the like) from saving properly. A fix is on the way, sorry for the trouble!

I’m having the same problem. I turn on Flip to Sleep but the beacon is still broadcasting and connects to the iPhone. I tried to change the setting in the cloud but the changes won’t update it stays in Pending Settings.

Any word on when the fix will be live?


I’m having the same problem with the “Dark to Sleep” mode. Even though I enable the “Dark to Sleep” mode, set the threshold fairly high, and save the settings (which are correct when I re-enter the settings area), the beacon still seems to be broadcasting when I put it in a pitch black place and values are showing way below the threshold I set.

Any idea what this is and/or when a fix will be in place? This was a pretty key feature for us.

Hello guys,

Just a quick update on the subject. The new version with the problem solved will be released next week. Sorry for inconvenience.


Has this been fixed? I am trying to test my app so flip to sleep would be really useful. When when I toggle it on, then save and disconnect from the beacon, it doesn’t flip to sleep, when I reconnect to the beacon flip to sleep is off, it didn’t save the setting update. Any solution available? Thanks

The issue reported in this thread (flip to sleep on Location Beacons + iOS SDK / iOS Estimote app) has indeed been fixed in the latest version of the app and the SDK.

Hi, apologies I’m using the Android SDK and Android app. I don’t know if you were aware but I seem to be having the same bug as was in the iOS devices. Is there a workaround or anything I can try. My beacons say they are up to date software wise.

Hi, sorry I figured out the problem from other threads. You need to have the accelerometer on in order to use flip to sleep.


Oh, thanks for sharing. That’s silly though, our app should automatically enable accelerometer when you enable flip to sleep. Gotta fix that!


I just got my shippment of proximity beacons and i turned on the fliptosleep in cloud.estimote.com, but beacons are not turning off. I see my change in Estimote beacon app. I’m using IBECON packets and IOS phone to test. Please advice

It will be very help to have this feature working.


With the new Proximity Beacons, the beacon does indeed turn off all of its packets, except for the Configuration/Connectivity packet. So if you flip the beacon to sleep, it should disappear from your own app if you use iBeacon/Eddystone, but it’ll still remain visible in the Estimote iOS & Android apps. This is intended behavior, although we certainly need to communicate it better (:

Long story short, flip to sleep works, no worries!

This beacon has pending settings and can not change according to the instructions you all give. “”""“Connect to it with the Estimote iOS Deployment App or the Estimote Android App to apply changes”""""" THIS DOES NOT WORK. I can change the settings on desk top then on mobile and nothing happens. Every beacon we purchased is more Viral Buzz hipe than reality. You all got the best platform. Its the best of the worst. Ok, I give you all the benifit of the doubt because it is a new idea but you all got to fix the simple stuff and don’t give instructions that don’t work.

You all are fast. Its fixed. At this point, you all are the best out of 7 other beacons we tried. Thank.