How do I activate ”Flip to Sleep” mode?

Hi there,

I’m new to Estimote and just received my first Beacons. I read the announcement on the example code repository about a ”Flip to Sleep” mode but can’t find much more about it.

How do I ”activate” that so that I can stop broadcasting from some of my beacons?



The easiest way now is to download our [Estimote 3.0.0 SDK][1] and build Examples on your device. After that update your beacons to the newest firmware with the Firmware update demo and connect to the beacon with the Beacon Settings. Click on ‘Flip to sleep’ and it’s activated :smile:

This feature will be also available in our official app in the next release.


1 Like

How exactly does ‘Flip to sleep’ work?
I have two beacons with A3.0.1 (D3.2) and have ‘Flip to sleep’ set to on using the new 3.0 SDK, but I have tried all kinds of positions, but they keep sending packages.

Just like in the attached picture. When ‘Flip to sleep’ is enabled and a beacon is placed upside down then it isn’t broadcasting.

How did you set ‘Flip to sleep’ mode?

I used my own App, and also tried with the ‘Examples’ App of the SDK. Reconnected to check the setting is correct, which it is, but the beacon up-side-down and tried finding it with the Estimote App, and it still appears. I was going to attach screenshots and pictures, but cannot do that as a new user.
I do use a custom uuid.

Please attach pictures, I’ve enabled that for new users. FYI I’ve just built Examples on my phone and ‘Flip to sleep’ works. Don’t worry, we’ll troubleshoot this asap.

Hello there - one thing that has occurred to me that’s may be worth checking… Have you enabled accelerometer? (either through SDK directly ESTBeaconConnection writeMotionDetectionEnabled:completion or in Estimote iOS app)… Flip to sleep needs the accelerometer enabled. If this is the problem we’ll need to make this clearer. Let us know if this helps?

1 Like

Thanks John, that was the issue. I didn’t have motion detection enabled, but now check for that flag when setting the ‘Flip to sleep’ and it work perfectly! Now test properly without having to move beacons three rooms down all the time!

Great. Glad that helped. Thanks to your feedback, and to try to make life easier for others we’ve added a log message if you try to enable this feature without accelerometer enabled, as well as making the documentation clearer. iOS SDK release 3.0.2 has the logging change, we’ll update the documentation soon. Thanks again for the feedback - it really helps us build a more usable SDK.

1 Like