Fliptosleep not working


I just got my shippment of proximity beacons and i turned on the
fliptosleep in cloud.estimote.com, but beacons are not turning off. I
see settings change in Estimote beacon app. I’m using IBeacon packets and IOS
phone to test. Please advice

It will be very helpful to have this feature working.



The problem is i’m seeing the beacons getting picked in didRangeBeacons method, even when it is flipped to back.

  • (void)beaconManager:(id)manager didRangeBeacons:(NSArray *)beacons inRegion:(CLBeaconRegion *)region {

self.currentBeacon=[beacons objectAtIndex:0];
NSLog(@" beacon:%@",self.currentBeacon);

The output
xxxx: CLBeacon (uuid:<__NSConcreteUUID 0x126a1ee90> xxxxx, major:66xx, minor:64xxx, proximity:1 +/- 0.24m, rssi:-59)

Is this suppose to do that ? Right now my only option is disable packets manually from estimote app.



Sorry, It did work, in the old beacons if i flip the flat side up it turned off. In the new beacons it seems to be the opposite.

Did that change ?


Looks like a bug :slight_smile: Should definitely work the same way as with the old ones, we’ll look into that.

A temporary workaround would be to … take the PCB out of the enclosure (there’s an opening in the back, behind the tape), and put it back reversed (: