Trying to configure beacons in admin app

Hi there!

I am building an android app and I am trying to configure estimote beacons with Eddystone Configuration GATT Service (without the SDK provided).
When trying to connect with mBluetoothDevice.connectGatt() I get the following error:

BluetoothGatt: connect() - device: F3:F5:23:77:66:6E, auto: false
BluetoothGatt: registerApp()
BluetoothGatt: registerApp() - UUID="…"
BluetoothGatt: onClientRegistered() - status=0 clientIf=6

and after 40 seconds

BluetoothGatt: onClientConnectionState() - status=133 clientIf=6 device=F3:F5:23:77:66:6E

It seems that I get a timeout error for some reason and thus the GATT ERROR appears. I used another android device and another beacon as well, but the same results. Is there anything that I may forget? Some extra security so that noone passing by can edit my beacons, and thus I am getting the error?

Have you enabled Eddystone Configuration Service on your beacon? (:

You can do it on cloud.estimote.com, with the Edit button, and then simply connect to the beacon w/ the Estimote app, and it should switch to the ECS mode.

Thanks for the quick feedback! Indeed I didn’t have this option enabled. But, I just tried and it doesn’t save the change, even when I configure the beacon with Estimote app. (No pending state icon either) Any ideas what I may do wrong? :slight_smile:

That’s likely related to that bug I mentioned here:

To enable ECS, you must disable all the packets first—normally there’s an error message to tell you that (: The reason is, once you enable ECS, it completely takes over beacon configuration. (No worries though, you’ll still see the beacon in Estimote app, and will be able to disable ECS if you want.)

Yes exactly. I started a new thread when I realized that it didn’t have to do with the particular setting. Indeed now, pending state is shown properly. But, even though I disabled all packets, saved and tried again, for some reason I am still not able to enable the Eddystone Configuration Service.

Hi Piotr!
Do we have an update about ECS?
I have disabled all packet types and change the ECS to ON. Estimote app is on and updating all changes done on the cloud except this one. (I have tried in all 5 beacons) In fact there is not a pending message when I change ECS status to ON.

EDIT: pending settings message appears normally when any other change is made.
Thanks :slight_smile:

Still working on fixing the bug that prevents error messages from showing, there’s likely some other error that prevents you from enabling ECS.

… which beacons do you have, Proximity or Location? I think herein may lie the answer, ECS is currently only supported by Location Beacons, but I noticed we incorrectly show the ECS option for Proximity Beacons as well in the Cloud.

I have Location beacons (2 candy, 2 lemons and 2 beetroots). I believe that the setting is not “saved” in the cloud so as to change the configuration in the beacon when the app is running. Every other change I make, I get a pending message in the cloud and when I run the app all settings are updated. However, no matter what I do, the setting for ECS is not “Saved” in the cloud.

Can you private-message me your Estimote Account login? I’ll take a look.

(Click on my avatar, and then the “Message” button.)

I’m having this exact issue right now… is there a resolution?