The Estimote app and Eddystone beacons

I have a bunch of Estimote beacons registered to my Estimote account. They came configured to use the iBeacon protocol, but I want to use the Eddystone protocol. No problem, I use the Android app to change their config, and they appear as Eddystone beacons. But then I realised I wanted to change the instance ID and so on. But they don’t appear in the Estimote app any more. The ones still configured for iBeacon are still there, and of the galaxy of apps available on the Play Store, none of them can edit the settings. They still appear in the list on but it will only update them if I use the app to refresh the data, which I can’t do because a) they don’t appear, and b) there is no update button on the app!

Have I bricked them? Can I change them back to iBeacon somehow? Can I change their settings with another app? Do I have to use the SDK to do this? If so why? This is certainly an exercise in frustration!

Barring some critical firmware bugs, it’s pretty much impossible to brick an Estimote beacon, so no worries (:

I assume these aren’t brand-new beacons? If yes, then the most common explanation in such situations is, they’ve run out of battery. In which case, you could try replacing them—peal the sticky tape off to reveal an opening through which you can pull the PCB out, and access the battery/batteries.

Just to be sure this isn’t some software bug, you could also try to detect them with another Android/iOS device.

Hey Piotr,
You’re right, they’re not new, but they came without batteries and already removed from their case, so I have replaced them with fresh batteries.
So what seems to be happening is that the ones that are using the iBeacon protocol (which is how they came configured), are detected by the Android Estimote app. For my application I need to use Eddystone (which isn’t my decision, sadly). So I changed a couple of them to use Eddystone UID. They now get detected by my app and other third-party apps, but don’t get detected by the Estimote app. What I hadn’t done was modify the Eddystone IDs to match our numbering scheme when I changed them over from iBeacon. None of the apps I have tried allow me to edit them, they usually say that they’re locked or protected, and as I said the Estimote app doesn’t even see them for me to be able to change features. So they’re effectively bricked for me if I can’t go and change them.

I have yet to try any iOS apps, but I can do if you think that will help.

I have just tried the Estimote app on an iPhone, and it doesn’t detect either the iBeacons or the Eddystone beacons! I am now at a loss as to what to do about changing the Eddystone settings.

Can you shoot us a message to with your Estimote Cloud email? We’ll check which exact hardware/firmware you’re on, and investigate/try to reproduce.

What iOS and Android devices and versions are you using?

Thanks piotr, I’ve pinged you guys an email. I am on Android 8.1.0 on a Nexus 6P, and the iPhone is a 6S+

Hi, I have run into the same problem: Changed the mode to “Eddystone” of 2 of my Estimote beacons and now they don’t appear in the app anymore. Battery is sufficiently charged and my other IBeacon-Estimotes can still be detected. May I ask if you guys found a solution for this problem?

@pirast What’s the hardware revision of your beacons, and is this on iOS or Android app?

I think there’s a known problem in the Estimote Android app, and the first-generation beacons, with hardware revision D3.4. The quickest workaround in that particular scenario is to … uhm, use the Estimote iOS app :innocent:

Hi, thanks. Yeah, they are based on HW revision D3.4. I had the chance to check with an iPhone of a collegue and unfortunately the beacons appear in the list neither. Do you have another idea?