Problem when using my friend's beacon

I borrow 3 beacons from my friend for my experiment. Unfortunately, I can’t use it properly, while trying to initialize I can’t receive its signal on my testing device? And his beacons is included in Preview developer kit (which he bought nearly 2 years ago). Did problem from beacon? Because of, they belong to my friend so that can’t see it details on estimate cloud.

Hey there,

If the beacons are two years old, it’s possible that the battery has died already. Please check with a 3rd party BT scanner (like Bluetooth Smart Scanner) if it’s possible to detect those beacons (make sure you have Bluetooth and Location Services enabled). If not, it’s the battery. To replace the battery (CR2450), you’ll need to cut the enclosures. Drop me a line to wojtek[at]estimote[dot]com and we can send you a new set of enclosures.


Hi there,
I thought it firstly too, but I tried to install Estimate app on AppStore, it can detect beacons. So I doubt on firmware of beacons is old and newest sdks (I use iOS SDK 3.3.1) so that’s it isn’t compatible with my SDK. Any possibilities for this case? And one more thing, I tried to debug to investigate whether mistake from me, but no error found. So that I thought problems from the compatibility of firmware (beacon) and SDK i’m using.

Ops! I found the root cause. Because of my project is a cocos2d sprite builder based, so that some of my framework impact to estimote and it need to investigate deeply. Finally I found the problem here. Thank for you support: Wojtekb.

FYI, we use our own SDK to build the Estimote app, so if a beacon works fine in our app, should also work fine in your own one (: And every beacon and firmware we’ve ever shipped is still supported in the latest SDK, we don’t plan to cut on the backward compatibility anytime soon.

Yep! The problem is, estimate sdk conflicts with some of mine sdks. I resolved this problem, thank you very much!