Error "Beacon not in range, has outdated software or is Virtual beacon"

Hi Estimote team,

My app is not able to connect to the beacons, I'm getting this error message: "Beacon not in range, has outdated software or is Virtual beacon", it also says that when I try to connect to them with the Estimote App.

I've tried:

  1. Restart the phone
  2. Turn off/on the bluetooth
  3. Delete, re-install the app
  4. Turn off/on the background refresh access

And nothing works, I have the latests iOS 7.1.1 and the latest Estimote SDK 1.3.0

Do you know if anyone else has experienced this?

Thank you in advance for your help.

Best regards,

Hi Ivan,

Actually, 1.3 is not the latest SDK. You can find version 2.0 on our GitHub profile: Also, make sure to update the Beacons's firmware to the latest available version through the SDK.

Let me know if this helps.

Hi Wojtek,

I was checking your repo and the 'master' branch shows v1.3.0 in the header files, the '2.0beta' branch has the 2.0beta version but it is still in beta, thats why I didn't use that version. Should I use the beta version?

Also, I haven't updated the Beacon's firmware because not even the Estimote App ranges the Beacons :(

Hi again,

Yes, please try the SDK 2.0. Also, are you able to detect the Beacons at all?


Hi Wojtek,

I upgraded the SDK to the latest version (2.0beta) and I'm still not able to see the beacons, I also downloaded the latest version of the Estimote iOS App and it is not able to see the beacons.

Hi again,

So now you cannot detect them any more? Do you recall what was the latest reported battery life?


Yes, I'm not able to detect any of the beacons, the last reported battery level was 1: Medium, 2: Low, 3:Medium around 1 month ago

If you cannot detect them after rebooting the phone and with any 3rd party apps like BLExplr, it probably means the batteries died. You can replace them (CR2450 or CR2477). The easiest way to do this is a vertical cut across the top of the beacon. Drop me a line to wojtek[at]estimote if you want new enclosures :)