Pending changes does not actualize beacons UUID - SOLVED

Hello. I want to change back a couple or our beacons to the default (B9407F30-F5F8-466E-AFF9-25556B57FE6D). I do it via cloud and it says that the Pending Changes will be passed to the beacons when the estimote app connect to them, but this isn’t happening.

What i am doing wrong?

I am sorry, it seems you have to exit-open the app .

Thanks for posting! We’re aware this “you need to re-open the app” is far from intuitive—we’re actually working on improving the Pending Changes mechanism right now, there should be an updated version of our app in the App Store soon, with some initial improvements. And then we also plan a follow-up release with even more.

Hi there!

I have a similar issue with UUID changing. I requested a change of UUID from the app on iPhone and I see the new UUID in both places: estimote cloud and app. However, the message “Pending changes” in estimote cloud did fade away, even though UUID is new. I restarted app on iPhone as @heypiotr recommended, but the message is still there. The problem is though - I am unable to track this beacon from my own app neither with an old UUID, nor a new UUID.

What else can I try to make the beacon work again?

Sorry Andrii, but exit-open the app worked for me.

If the beacon doesn’t show up in the app, that means the app likely can’t detect it, and because of that it also can’t apply the pending changes. Maybe the battery in your beacon died? Does the beacon show up in generic BLE scanners (e.g., this one:, it should be showing up on the list as “EST” or “estimote”)?

Ok. So, I used the BLE scanner suggested by @heypiotr as well as eBeacon (, and I can find this problematic beacon in both apps. After scanning with BLE scanner the message “Pending changes” mysteriously disappeared, even though it was there for the last 2-3 days. So, it seems like the battery is still doing fine :sunny:

Now apps:

  1. Estimote app: I can see a beacon there as before.
  2. My own iOS app: I am not able to track this problematic beacon from my own app. I use the same code as for another beacons which I can track. But when I use the same code for a problematic beacon with a only difference in UUID, major and minor I am unable to track it. I have no idea what the reason is. By the way, for some reason IDs I see in the scanner apps do not match UUIDs. Should it be this way?

The IDs in the scanner apps are actually not iBeacon UUIDs, so that’s okay.

If you can see the beacon in the Estimote app, can you check if the UUID shown in the app matches what you’re using in your own app? If the Estimote app can detect the beacon, there’s no reason your app shouldn’t be able to do it as well.

Yes. UUIDs (as well as major/minor) in the Estimote App are the same that I use in my own app.

Got it, so something with your app then. Do you mind opening a fresh topic and posting some more information about your app in it: do you use Estimote SDK, ranging or monitoring, maybe provide some code snippets, etc. One thing that I think is immediately worth double-checking is the Location Services authorization.

Ok. Thanks @heypiotr . I will.