No application works for my Beacons

Hello. In the Estimote Application the only functionality that is working is (Devices). All others do not work. No beacons is found.
Proximity Demo, Distance Demo, Notify Demo. None!

I am struggling to develop my own application from the documentation and also using the demo applications, but nothing works. Not even the Demo applications!

I use the default UUID since I bought them, I never modified them, and they never worked. B9407F30-F5F8-466E-AFF9-25556B57FE6D.

Anyway. I read everything I could and researched here in the forum for solutions, but I really can not understand what is happening

My Beacons:
Location Beacons OS 4.9.4

My Device. Lenovo L10a40.
Android 6.0

Hi, again. I tested the tests using a Azus Device, running Android 5.0 And it worked correctly.

So now I have the doubt about the Lenovo.
The problem is my device? Operational system? . System version ?.

I have already enabled access to all necessary requirements, Bluetoo and Location.

As I mentioned above, neither Estimote’s application nor self-made applications with the Most recent SDK work!
Can you please help me?