Eddystone-URL How to setup (basic test)

Hello,

  • I have a Estimote Beacon.

  • Want to test quick with Eddystone-URL - and wondering what steps i need to do.

  • I was thinking this - and lost at number 3:

  1. Login to cloud.estimote.com
  2. Find my beacon - and set Eddstone-URL
  3. Start some app to push that setting to pus that setting to the beacon?

Thanks for help,

Best regards,
Johan

1 Like

also a newbie here, this post has not been answered, can someone experienced or a Estimote dev team member help out?

Sure! (:

It’s as simple as downloading our “Estimote” app from App Store / Google Play Store, finding your beacon on the radar, tapping on it, and once the app connects to the beacon, change the Packet Type to Eddystone-URL.

It should be too simple for me…:confounded:

I set one of my beacons to Eddystone-URL, I let the default url http://go.esti.be but I don’t see anything coming on my iPhone 5C 10.1.1 or my Nexus 7 2013 6.0.1.

I also tried https address such as https://blog.beaconstac.com/, same.

Any idea?

Maybe this well help (:

Eddystone-URL and Physical Web: All You Need to Know

Thanks for the link heypiotr but strangely, if I follow the article and go Chrome’s Privacy->Physical Web->See nearby urls, I effectively see the url broadcasted by the beacon but it doesn’t generate any notification on Nexus 7 2013 LTE, nor on Nexus 7 2013 Wifi, nor on Galaxy S4 Active, nor on Asus ZenPAD7C. :confounded:

This is the problem i am having. No fix yet.

I’m having an issue with two beacons not responding…can i get some help?

I assume that by not responding you mean you cannot get Physical Web notifications.
What phone are you using? Android or iOS? Because Google dropped support for Physical Web on Chrome iOS, see this thread: Google stop supporting physical web on chrome IOS

Physical Web notifications are only displayed when they meet some conditions (for example they are using https). They are also checked against spam filters. From https://google.github.io/physical-web/try-physical-web:

Additionally, nearby broadcasted URLs must be public. The URL will be accessed by a Google service to resolve the URL and retrieve page metadata. If the page is not accessible from the Internet (for instance, it requires authentication or is only accessible from an internal network) then it will not appear in the list of results.

Finally, all URLs must resolve to an HTTPS URL. For our users’ security, we require all Physical Web pages be served over HTTPS. You may use a URL shortener that generates HTTP URLs as long as the shortened URL resolves to an HTTPS URL.

Some more information can be found here: https://google.github.io/physical-web/faq

I am not using a shortener. The issue seems to be the beacons not syncing with the estimote cloud. I have three beacons, one works fine. The other two have been in Pending Settings mode via the estimote web site for five days. When using the estimote app, I get a continuous spin cycle with two non working beacons.

1 Like