Can't detect beacons with estimote android app

Hi, I’m using latest version of Estimote app from Play Store, 3 beacons from Estimote Dev Kit, Huawei P10 Lite with Android 7.0.

When I go to “configuration” at the Estimote app I cannot find any of the 3 beacons…

Any help please?


Can you double-check if you have Bluetooth and Location enabled?

Are the beacons brand-new, or is it possible they’re out of battery?

yes…bt and location enabled.
new…and they are detected using ios app…

Hello everyone,

we’re experiencing the same issue with Huawei smartphones. Can someone tell us more about the issue?

Also, someone could open an issue in the bug tracker.

Same here on my Oppo Find 7 and Motorola Moto G 2014, both on Android 7.
Had this problem a few weeks ago and contacted the support because I also could not log in. Everything seemed ok from their site, so the support didn’t know a solution. Then using an Iphone I somehow found them, and it worked on Android again. Now I can’t find any of my beacons again with Android. Double checked BT and Location, restarted phones, cleared Bluetooth data, logged out in the Estimote app, even opened one of the beacons, removed the battery for a while to restart the beacos and also checked the batteries’ voltage (3.0V = completely charged).

When using a 3rd party scanner on Android it takes a long time (15-60 seconds), but I can find them (they show the iBeacon protocol). When using the new Estimote Monitoring 2.0 Android SDK (the demo app included) the beacons are found after 2-5 seconds on every try.
Here’s the proof:
I read that the old SDK doesn’t get any updates anymore. Is the Estimote App from Playstore based on the old SDK or already on the new one?

EDIT: Again, testing on an IPhone, I find all of my beacons within 2-3 seconds.

This makes it completely useless for any real life application, if I can’t even access them in my android development phase. So what’s wrong with the Estimote app? I tried the newest update from today (2.5.0), but no change. I appreciate you update the Android SDK now, but Android has been neglected for too long. I own those beacons since the beginning of 2017 and many people and I had trouble since then. I understand that Android, due to its diversity, is more complex but still…if it doesn’t work ~100% like with an Iphone client, maybe don’t sell it as Android supported until the problems are solved?

Is there anything being done to fix this issue? I have tried on a Nexus 6, Nexus 6P and a Huawei Mate 10 without luck, in each case Bluetooth and location were confirmed turned on. So that is both on android 7 and 8. Two ios phones picked up the beacons right away.

That is strange. I’ve seen Nexus 6 scanning beacons without a problem. Scanning issues with Androids 7.0 and 8.0 were already fixed in Proximity SDK (which is used inside app). Are you sure you are running app version 2.7.3 (112)? Can you provide logcat dump? Maybe there will be a clue. btsnoop log might also be useful.

It’s never worked for me either on my Nexus 6P with Android 7 or 8. Other apps work fine including my own ReactNative app.

it happens when your Mobile Phone is not compatible to locate the beacons. Change your cell phone and cross check it.