Android tutorial only works when Estimote app is opened

I’ve been following the Android tutorial. Surprisingly, it only works if, after launching the example app, I open the official Estimote App, and touch Configuration to show the beacons in range.

This same behaviour happens when executing the example Notifications taken from the Estimote SDK for Android.

What am I missing?

I also have the exact issue. I used device with Marshmallow. But it worked on another phone with lollipop!
Earlier, it was not starting th .Myapplication. I tried to configure the beacon that was referred in the app (increase /decrease transmit or range…) and then it started to work.
Any help is appreciated!

In my own particular case, I’ve been testing with an Android 6.0 Marshmallow device. It seems there is a missing step in the tutorial, something that activates Bluetooth scanning, but I don’t know what could it be.

I’ve been testing with an Android 5.0 (Lollipop) device and the tutorial it’s working. A pity it doesn’t work with the Android 6.0 and 7.0 devices I’ve tested.

Just for your information, I’ve just tested the sample app with the new SDK 1.2.0 with identical results.