Unable to change Primary Packet Type (iOS)

I have read another post with this problem, which magically was solved. I haven’t been that lucky so far.

I am trying to set my new 3 Estimate beacons to Primary Packet Type to iBeacon. I can change it but when I go back to the “radar” view and select the beacon, or another beacon, I see that the default setting, “Estimate Default” is there again.

Using a third party iBeacon scanner I see that no estimate beacons are detected.

Any ideas what can be wrong?


Estimote Default should still be discoverable by iBeacon scanners. Which scanner do you use? Maybe it’s scanning for the wrong UUID, Estimote Beacons ship with UUID set to “B9407F30-F5F8-466E-AFF9-25556B57FE6D” by default.

Thanks… so if I understand correctly, I don’t really need to set the Primary Packet Type to iBeacon to be located by iBeacon apps, as “Estimate Default” as Primary Packet Type should be enough, am I right?

Anyway, please note that I can’t force iBeacon in my Estimote Beacons, as they always go back to Estimote Default. Also, in Android App the iBeacon mode is not visible.

I’ll test with more Apps leaving “Estimote Default” setting. Thanks.

I am having the same issue. Setting the beacon via the app to “Apple iBeacon”, it shows “Estimote Default” as Primary Packet Type after restart. iBeacon scanners do not regonize it.

“Estimote Default” is actually the same as iBeacon, except we allow changing the advertising interval to something else than the 100 ms required by the iBeacon spec. (If it’s anything other than 100 ms, then we simply cannot call it “iBeacon”, hence the “Estimote Default”.) If you want your Estimote Beacons to broadcast a fully-iBeacon-compatible packet, just set the adv interval to 100 ms.

Nevertheless, from my experience, even if it’s not 100 ms, iBeacon scanners should still pick it up. Which scanner are you using?

It works fine with the Locate app from Radius Networks.

But my own code (plain CoreLocation) still only occasionally recognizes the beacon.

EDIT: Ranging works fine now with CoreLocation. Region monitoring still doesn’t detect the beacon most of the time.