Unable to change Primary Packet Type Android

I’m using the Estimote application for Android and need to turn on Eddystone-URL. My beacons are connected to my account and I’m able to change the name of the beacon. However whenever I select the Eddystone-URL from the Primary Packet Type section it says

“Unable to change Primary Packet type”

I’m able to change pretty much any other setting. Are there any prerequisites for turning on Eddystone-URL such as Tx Power or the UUID? Any help would be appreciated.


For anyone reading this I updated the firmware and it seems to have solved the problem. Perhaps that was the issue or another setting was refreshed in the process. Might help someone else having the same problem :smile:

Thanks for the note @karim! Eddystone support was added in firmware 3.1.0 or 3.2.0, don’t remember exactly now, that’s why updating firmware solved the problem. Now, we just need to teach our app to show a more descriptive error message when this happens :slight_smile: Thanks a ton again!