No connection to cloud error


#1

Hi,

I am trying the new mirror beacons and I encounter a problem.
I try to access internet but I am not able to connect to the WiFi:

No Connection to Cloud
Unable to connect to the internet using access point named ****

I searched in previous topics but none spoke of this :confused:

Thanks for answers :slight_smile:


SOLVED: Mirror wifi woes + demos not demoing
#2

This message means that Mirror is not able to connect to Cloud. It does not necessary mean that WiFi is down. Make sure your WiFi network can connect to cloud.estimote.com and there is no login page (like in airport/hotel networks).
If WiFi is the problem then I assume you have tried to reboot the device and it did not help. You may also check if your Wi-Fi password is correct (and does not contain for example a space at any end).
You may try to set up an access point using your smartphone and check if it will work with Mirror.
Some Wi-Fi routers (especially those used in corporate networks) may need to whitelist device MAC address.


#3

Hi,
I triied every thing you said except passing through a mobile phone. I’ll try this.
The password did not contains any space but the WiFi name does, is that a problem ?
Thanks for the answer


#4

It should work with space inside WiFi network name.


#5

I triied to connect with my mobile phone cellular network but it does not work.
I also triied to downgrade my WiFi from WPA2 to WPA and then WEP, with no results.
Each time I have this connection to cloud error. Some times it does not appear but the connection is not accessible.


#6

Sometimes it needs to be rebooted for WiFi to kick in. It should work with WPA2 with no problem.
I suspect your device may have hardware problem. Have you tried to test WiFi on another unit?
There is one thing you can check. Mirror has a built-in internal template called estimote/scanner. When you select it with parameter mode equal to wifi it should show you available wireless networks. You can add this line to default template to make it switch to scanner:

mirror.selectTemplate("estimote/scanner", {"mode":"wifi"})

This way we can verify if WiFi hardware is working.


#7

OK, I selected the template on my 3 mirrors and only one of them found WiFi networks.
So I guess the two others have hardware problems ?
For the one that found WiFi, the connection to cloud failed again. However, when I look at the informations of my mirror on the cloud in the “WiFi Network” section the “Status” field is “Connected”.

For the two that does not work, do you have a replacement policy ? Because there is only one working on three received :confused:


#8

I ran into the same issue about the Wifi. I would be nice to have some documentation about the template you mentioned.

I have an other question about internet connectivity :
Is it possible from the mirror to call request to an external API over the internet or a local server ?

Every request we launched result with an error. (Depsite of being connected, the mirror is connected to the cloud) The same code will work on a regular browser, it’ll only fail on the mirror. We supposed that maybe it’s not possible to call external url.

Thanks for your reply


#9

Those templates are for internal use only (debugging, testing, etc.) and they may change without notice, so no plans to document them.
It is possible to call external APIs. Mirror verifies every URL it opens against preconfigured whitelist. You need to set it in the cloud and synchronise with device (manually using Bluetooth or automatically if WiFi is configured).
Make request to https://cloud.estimote.com/v3/devices/{MIRROR_ID} to allow all hosts:

{
      "identifier": "{MIRROR ID}",
      "pending_settings": {
      	"general": {
      		"whitelisted_domains": ["*"]
      	},
      	 "advertisers": {}
      }
}

You need to have Acces mode set to development. Otherwise you need to include AppID and AppToken in header.
Other important thing you have to be aware is that Mirror loads templates from local web server. So when you start the device it will display template immediately, but any request to external server will fail because WiFi needs few seconds to connect (depends on wireless network). You need to handle this situation for example by retrying request couple of times when it fails.


#10

Have you enabled WiFi on all three devices? If you don’t have it turned on, you will see empty list.


#11

Thanks for the answer, I am now able to call external API through WiFi on one of my mirror, Peter’s question was my problem too.
For the two others, I have enabled WiFi and still have empty list, so I guess it’s an hardware problem.
So, do can we replace them ? Is there a number to call or a mail to send to someone that can answer the replacement question ?


#12

I have the same issues with my Mirrors. I have activated the scanner template and see all available networks, my own network on top. I entered the correct login/pw for the WPA2 connection, reset the router, upgraded firmware, plugged the Mirrors out/in again (I assume that reboots them?), etc. I’m using ‘N’ wireless mode only btw.

The Mirrors still will not connect to the network.


#13

2 Mirrors out of 3 in previous posts showed no networks at all, which was likely a hardware failure (one Mirror was connecting to network).
In your case, Mirror can see your network on the scanner, but it is unable to connect to it. I assume they all behave in the same way. This suggests that there might be an issue with WiFi network (weak signal, low level protocol problems, MAC whitelisting, login page, etc.) .
What is your network signal level on the scanner? If signal is too weak Mirror might be unable to connect to network (or it may take a while).
Have you tried to make Mirror connect to WiFi hot spot created on mobile phone as suggested in previous posts? This would help to rule out weak signal since you can move phone close to the device.


#14

Right, so I did some more testing and followed your suggestions. All three Mirrors have the same problem.

The router is configured without MAC whitelisting, login page, etc. Anyone can connect as one normally would in a home network. (user/pass, WPA2 personal). Other devices can connect, from phones, laptops, to raspberry pi’s and obscure chinese webcams, even from other rooms/floors. Changing to an open network also did not help. Using a different brand router also did not work.

The signal level that the mirror display next to my network name is: 47

Connecting to a wifi hotspot on my phone (held close to the device) also did not work.


#15

Hi Michel,
Could you write to contact@estimote.com once again with a brief summary of your issue.
I’ll get back to you as soon as I receive your message.

Greg