Motorola MOTO E & Estimote App - no detection [SOLVED]

dear all,

quick question: are there known issues with MOTO E and your app?

the app does not detect a single beacon, whether estimore or other.

Other iBeacon apps on same phone work nicely,
and other devices (e.g. BLE dongle on laptop) see the Estimote Beacons without probs.
So we ve narrowed down to the prob being
Estimote App on MOTO E:
Or what am i overlooking / doing wrong?

thank you in advance,

regards,

Sebastian

We don’t have Moto E to replicate problem. Try to compile and run Estimote SDK Demos and see if the problem still exists. If so, then please provide us with some logs from that application. Are you running Android 5.0 Lollipop or some other version?

Thank you. I have now tried with SDK, and your “Gate closing” demo, and compared with a working phone:

not working:
MOTO E
Android 5.0.2

working:
NEXUS 5X
Android 6.0.1

the code builds without errors, app runs without any errors - there s just no registration of any beacons.

Are there higher minimum requirements than 5.0.2?

SDK should work from Android version 4.3 (API level 18), however early Android BLE implementations were pretty unstable.
You may try to use following flags in AndroidManifest.xml in application section:

<meta-data android:name="disable_batch_scanning" android:value="true" /> 
<meta-data android:name="disable_hardware_filtering" android:value="true" /> 
<meta-data android:name="force_old_scanning_api" android:value="true" /> 

Please add them one-by-one, checking which one will make beacons to appear in app. I suspect it might be something with hardware filtering (not all devices support it and few applications use it) .

Thanks & [SOLVED]

Following your advice, @pober -
trying to make MOTO E work:

adding one at a time in AndroidManifest.xml,
inside application BUT outside activity:

1/ 

<meta-data android:name="disable_batch_scanning" android:value="true" /> 

==> no change - no registration of beacons

2/

<meta-data android:name="disable_hardware_filtering" android:value="true" /> 

==> change!!! - registration of beacons working!

Does it work with just 2/ ?

yes!
‘disable_hardware_filtering’ makes the difference.

1 Like