LTE beacon 'stuck' on firmware version 0.0.3

Hello, I have a developer kit of two LTE-M beacons for several months now - one beacon has updated its firmware successfully to version 0.0.15, however the other one is seemingly ‘stuck’ at version 0.0.3 - I have already searched the forum looking for possible solutions, and have tried “holding both the top and side buttons for over 10 seconds” to force an update, as well as switching the heartbeat period to daily - the device does appear to ‘try’ to update its firmware but apparently never succeeds.

This lack of successful updates has not been a true issue until now, as I am now seeing functional differences between the two devices - for example, running identical ‘micro apps’, the 0.0.3 device can never acquire GPS location, while the 0.0.15 device works perfectly.

The 0.0.3 device is generally functional in all other respects - connects over LTE-M fine, accelerometer , temperature sensors work fine, etc.

I am wondering if I somehow have a defective device, or there is something from the Estimote Cloud ‘side’ that can be done to force this device to update its firmware.


Hi there, and thanks for trying the LTE Beacons! (:

Can you let us know the identifier of the beacon, so that we can look at some data on our side?

Sure - it’s 786616157e3a022ebf714436be600718 - Thanks!

Hmm, nothing obviously wrong jumps out. Maybe @pober will have some idea.

the device does appear to ‘try’ to update its firmware but apparently never succeeds.

So the LED starts blinking, and then what happens? Any chance you could post a short video?

The device stuck at firmware version 0.0.3 appears to function in a very similar way to the other one that’s currently at firmware version 0.0.15 when it performs its “heartbeat” - the center ring LED’s blink green rapidly, sometimes for 10 or so minutes at a time, then stop, however after the blinking stops, the firmware version remains at 0.0.3 - I am retrieving the firmware revision number through the Estimote Cloud web page. Are there perhaps some ‘firmware upgrade log files’ on the device itself I could locate and upload to you for diagnosis? Perhaps there is a way to establish a “Terminal” connection over bluetooth with the device?

Today I tried again to force a firmware update by holding the top and side buttons for 12 seconds but was not successful - in fact, the device seemed to have ‘frozen’ and became unresponsive, however once I connected , recompiled and sent my microapp to the device it seems to have recovered. The firmware revision is still reporting as 0.0.3, and acquiring GPS still does not work, although the other functions such as LTE-M connectivity, accelerometer, temperature, all are working. I have a demonstration scheduled with a prospective customer soon which requires showing GPS working, so I’d really like to have this problem resolved, or perhaps I could return this particular unit for a replacement?

One follow up question (which I am researching myself) - was the GPS API in version 0.0.3 functional, or perhaps had different function names / parameters, and perhaps this is why GPS is not working on this particular LTE-M Beacon? Thanks!

Hello! Some more observations with my LTE-M beacon ‘stuck’ at firmware revision 0.0.3 today - I have had the device on ‘wall’ adapter power for many hours, and have observed at least twice where the device attempts a ‘heartbeat’ - the center ring flashes green for approximately 2 to 5 minutes, and when the flashing green light stops, and after waiting a few minutes, I connect through the Estimote Cloud IDE , I see the firmware revision is still 0.0.3. Furthermore, I notice that when this device does a cloud sync (triggered by a button press event), the cloud sync is successful, however the device immediately drops its web bluetooth connection with the Estimote cloud IDE. My other LTE-M beacon, which is at firmware revision 0.0.15, does not drop its web bluetooth connection with the Estimote Cloud IDE when a cloud sync is triggered by a button press - both devices are running the same ‘microapp’ source code.

Could Estimote possibly supply me with a firmware update utility program I could use to update this problematic device’s firmware through its USB-C connection (does the USB-C connection support serial communications?)


I am trying to manually cause a firmware update again using the “press top and side buttons simultaneously for 10 seconds or longer” method - Now I see the day/week/month LED’s cycling on and off in order, and hopefully this means a firmware update will be triggered. Device is on ‘wall’ power, not seeing the center ring flash yet.

Update - I repeated the “hold top and side buttons in for 10 seconds to force an update” procedure several times over the weekend - I observed that once the update process has started, the day/month/year LED’s blink in sequence, then the sequence speeds up, then the center LED ring flashes for approximately one minute before stopping, with the device firmware remaining at version 0.0.3.

I am wondering if there is anything else I may try , such as perhaps forcing a ‘hard reset’ on the device, or if Estimote has a firmware / software update utility I may try locally. Also, I am wondering if Estimote may be able to determine more information by checking any logs from the . Estimote Cloud when updates were attempted - for example, does each update fail at the same point in the firmware file transfer, perhaps because of a bad checksum, or perhaps the device not having enough storage space remaining to fully download the firmware update?

Hey mdoser, I’ve sent you a private message!

A post was split to a new topic: LTE Beacon order ETA


I’m not sure if there was a miscommunication, however I have not received the “Return Materials Authorization” information so I may ship back my LTE-M beacon stuck on firmware revision 0.0.3 and have a replacement sent to me - could someone follow-up on this issue? Thanks!

Hi there! I sent you an email with the necessary documents yesterday. Please check your spam box and let me know if you were able to find it. If not, please provide an alternative email address, and I’ll resend the free label.

Hello Timo! I have shipped the old device and already received the replacement - The replacement device however is not assigned to my Estimote account, so I can not access it - would you be able to assign this replacement device to my Estimote account? Thanks!


Thanks for reaching out to us!

If you could provide me with the beacons’ IDs (we explain how you can find them here), I’ll be able to assign them to your account manually.


Thank you Timo, however Jakub has already resolved this issue for me. Apologies for not remembering to notify you my issue was resolved!