LED ring on LTE beacon blinking continuously


#1

Hi,

I’ve been experimenting with my LTE beacons today and have pushed an app (based on the alert button sample) to one of my beacons. This all worked. But a few seconds after I disconnected from the beacon in the browser the LED ring on the beacon started flashing continuously. The ring turns on and off several times a second.

I think the beacon is trying to tell me something but what?

Detailed description:

  • The LED ring blinks several times a second.
  • The LED color is green.
  • The LED at the top of the beacon (near the cloud icon) is brighter than the bottom.
  • I can still connect and disconnect from the beacon.
  • The code on the beacon (based on the ‘alert’ template app) seems to be running just fine.

I hope that someone can tell me why my LTE beacon is flashing so enthusiastically.

Sincerely,
Steven.


#2

After an hour or two the LED ring stopped blinking.

Any suggestions as to why the beacon flashed the LED ring?

Steven.


#3

Steven,

since the LTE Beacon tech stack is relatively new we continuously make progress both with Cloud UI, mobile apss as well as LTE Beacon firmware and the “virtual machine” that is interpreting JavaScript.

What you have experienced was probably an over-the-air LTE Beacon firmware update.
You can check which version you have in the Cloud under LTE Beacon settings.
As of today (end of January) the current version of the device firmware is 0.0.7.

Please note at the moment firmware updates are done automatically. We simply rollout
it to the devices we have shipped. This is in order to fix some minor issues our early customers have reported.

We are also working on a Cloud UI switch you can manage “automatic firmware update”.
So in near future you will be able to decide if you want your device to be automatically updated
or if you want to trigger that manually.

Thanks for testing or products and your feedback!


#4

An over the air update sounds right, the beacon concerned has a new version number for the firmware.

Thanks for the clarification,
Steven.