iOS Templates don't work

I create an app on estimote cloud and download the template. I am not much experienced in iOS but I install the pod file and everything but my xcode project fails to build. I tried a couple of different templates.
Can someone point me to a reference on how to build one of these templates.
Thanks.

Can you post what the errors are?

Right now I was trying a Notification Template and I get
library not found for -lPods-Notification

This means you’re probably opening the .xcodeproj file (Xcode project, blue icon), and you should be opening .xcworkspace (Xcode workspace, white icon).

You need to use the workspace, so that it opens/uses both the project with the template, and the project with the dependencies required by the template (most notably, the Estimote SDKs).

Let me know if that helps.

My bad… that was a noob mistake …

Oh don’t worry, little things like that happen to me all the time :smiley: One day I’m writing sophisticated piece code, another day I write !foo == true instead of foo != true and wonder why I’m getting a lint error for “confusing usage of ! in a conditional” :stuck_out_tongue:

Also, make sure you ensure the pods are updated to latest version in the pod file. If memory serves me correctly, I had to remove the ‘version lock’ it had for each of the pods otherwise the templates wouldn’t compile with Swift 5 (Xcode 10.2).

Yaa agreed…That was a noob mistake…I guess it must have been solved now.