Integrating the ProximitySDK into an iOS framwork

Hi there,

I am currently trying to integrate the ProximitySDK into my framework (creating a nested framework so to say), but Xcode complains that it cannot find the lib unless I add it to both the framework and the app implementing the framework, which i do not want to do.
Do you know this error and a possible solution? I installed the framework manually as described on Github.

Error message:

dyld: Library not loaded: @rpath/EstimoteBluetoothScanning.framework/EstimoteBluetoothScanning Referenced from: …
Reason: no suitable image found. Did find: …: code signature in … not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.

Thanks in advance,

I changed the Trust on my Apple Worldwide Dev Relations Cert to “Use System Defaults” and that seemed to do the trick. Please read on as you may have a different experience.

You hit the jackpot with this error message and I’m betting it affects every non-Apple framework you attempt to link by drag and drop or through a pod spec. Appears that this only affects “dynamically” linked frameworks and not statically linked. Since you don’t have control over the linking of the third-party framework, you’re stuck.

I tried everything to fix this issue including getting a second paid developer account, but the issue remained. I also tried creating a dev provisioning profile (not the “Automatic”) and that too didn’t work. The distribution provisioning profile seemed to work without a crash, but the device screen is blank, i.e., no user interface…might as well have crashed.

I suspected my dev profile may have been corrupted and nothing I tried in Xcode or Key Chain seemed to fix it.

Good luck.

Hey Mark,
Thanks for the reply, sadly this setting was already checked on my side.
Any further ideas?

In all my research, there appeared to be hints about Xcode 11 is when this issue started popping up. In my case, all my tools are beta versions, Mac OS, Xcode, and iOS. I don’t have a way of isolating this issue to a version to know for sure.

For sure, this only impacts app with non-Apple frameworks that are dynamically linked–I know, as I tested it with my framework.

Perhaps our good friends at Estimote can make available a version that is statically linked.