Estimote cloud generated "proximity content for a single beacon" build failure + others

Hi, I’m running 10.11.4 with the latest Xcode.

I went into my estimote cloud space and went to create a new "proximity content for a single beacon’ app, downloaded it and ran it. It fails to build because of a "use of unresolved identifier ‘ESTRequestBeaconDetails’ see screenshot.

on a side note I tried to get the latest 4.0 framework via the cocoa pods, after it installs it generates a “Error:(22, 17) use of undeclared type ‘ESTDeviceLocationBeacon’”. That file was not in the pod.

on another note, I cloned the iOS estimote sdk repo and tried the swift examples with carthage (configuration) and it generates a “ObjCBridge.h:4:9: error: ‘EstimoteSDK/EstimoteSDK.h’ file not found” no matter how many times you drag the framework into the project.

It seems impossible to get this stuff going, any insight into these would be appreciated.


Thanks a ton for the report! We fixed both bugs:

You will need to generate a new “ProximityContent” app in the Cloud, so that you get the latest version of the template.

1 Like