Flip to sleep issue

#1

Hello,

I bought recently two boxes of proximity beacons and I am trying to configure the flip to sleep option by using the iOS Estimote App.

Testing it with an old beacon (hardware D3.4 and software A3.2.0), the device appears in the radar, the beacon in motion could be selected and I can see a switch control by enabling or not the accelerometer. In this case, the flip to sleep option could be activated and it works as expected even if the beacon is moved the iPhone vibrates and the icon moves. Moreover, if the device is flipped it does not appear in the radar option.

If the test is carried out with the proximity beacon, the beacon in motion option could be selected and the switch of Flip to Sleep Mode appears. The option is on, but the beacon icon does not move if the beacon is moved and the iPhone does not vibrates. Moreover, there is not an option for enabling or not the accelerometer. The hardware revision is J1.9_B1.1 and the firmware is 4.14.4. The beacon in always in the radar even when the flip to sleep position is used. Looking in the broadcasting tab, monitoring, telemetry and iBeacon are enabled.

Thanks and regards,

Juan Antonio

#2

Starting with firmware 4.x, accelerometer is managed automatically, that’s why you no longer see the option to turn it on or off.

Also starting with firmware 4.x, flip to sleep doesn’t affect the dedicated connectivity/configuration broadcasting, which is why you will always see the beacon in the Estimote app. All the other packets are properly disabled though, so for example, your beacon while flipped will not show up in iBeacon ranging, or won’t generate enter events in the Proximity SDK.

#3

Thank you for your answer. I understand it now.

Regards,

Juan Antonio