Estimote Cloud - Enabling Flip-To-Sleep Doesn't Enable Accelerometer

I am about to deploy 50 of the 1st Gen Estimote Beacons. I’d like to enable flip-to-sleep on all of them. I am able to turn on Flip-To-Sleep in the Estimote Cloud interface and the app appears to apply the changes, but flip-to-sleep is never enabled. I’ve read in other forum entries that it is necessary to enable the Accelerometer in order to enable flip-to-sleep. As far as I can tell, the accelerometer is not automatically enabled for flip-to-sleep and there is no place in the cloud UI to enable it in bulk. The workaround seems to be that I’ll need to configure each beacon individually to enable the accelerometer and then enable flip-to-sleep. Have I missed something?


No, you haven’t missed anything—it looks like we did though :sweat: Having bulk-edit for flip to sleep, but not for the accelerometer is indeed quite an oversight on our part. (We learned our lesson, and in the next-gen beacons, the firmware itself will enable the accelerometer if you enable any features that require it.)

So for the moment, sadly it does look like you’ll have to enable it one-by-one, or write a simple app with our SDK that’ll connect to each beacon and enable the accelerometer and flip-to-sleep. (Using the regular connection/management API for the 1st-gen beacons, i.e., ESTBeaconConnection; and not the ESTBulkUpdater.) Sorry for that!

Thanks for confirming, Piotr.