Eddystone URL Nearby Notifications


#1

Are Google Nearby Notifications working already?

I am trying it with an Estimote beacon configured to Eddystone URL, Google Play Services 9.2.56, Android 6.0, Moto E (2nd Generation), 4G LTE

Bluetooth ON, Location ON, Proximity Discoveries ON


#2

Solved. A HTTPS url is needed.


#3

Hi, Does this only work using EddyStone URL packet? I’m trying to do this using an attachment on a EddyStone UID packet, but I’m completely unable to get anything to show up. PRoblem is persistant across a range of devices… :frowning:


#4

Hi, I did not tried it using UID packet yet.

Anyway, you should follow instructions on https://developers.google.com/nearby/notifications/overview

Sorry.

:neutral_face:


#5

@salberink, you need Google Play Services version 9.2.55 AFAIK, although I think at this point it should’ve propagated to most Android devices.

To further troubleshoot the problem, I’d say go to Setting => Google => Nearby discoveries, hit the refresh button and see if your Nearby Notification shows up in there. I just tried attaching a URL notification to my Eddystone-UID beacon, and it shows up in there, but I’m also having a hard time getting it to show up as a regular notification—not sure exactly how it’s supposed to work.

Some other ideas: you need to have Bluetooth on (quite obvious), Location on (less obvious, but also required), and have Internet connection, so that the Nearby Notification can be resolved via Google’s Proximity API.


#6

Hi Piotr,
Thanks for the additional suggestion. Wanted to ask if you had additional ideas.

My trusty Android Chrome is still not performing as expected.
(Nexus 5x, Android 6.0.1, Estimote 3.2.0, Chrome 52.0.2743.98)

Everything is kosher on the beacon settings end of things:

  • Beacon has latest firmware
  • Beacon configured to Eddystone-URL
  • Desired public site uses HTTPS. URL shortened w/google shortening service.
  • Beacon is right next to phone, beacon not sleeping, power set to -20dBm, 500ms broadcast interval, smart battery saving “off”.

On the phone side:

  • All antennas on (Btooth, WiFI, Location, cell antenna)
  • Chrome Physical Web “on”
  • Chrome access to location “on”
  • Chrome notifications “on”
  • As you suggested: Google > Nearby = “on” (beacon doesn’t show up in Google > Nearby Discoveries)

Are there other settings/avenues I’m overlooking?
Thanks in advance.


#7

Hmm, just one more idea:

Go to Chrome, Settings, Privacy, Physical Web, See What’s Nearby, and check if the beacon shows up there.

If that doesn’t help, IDK, maybe a bug report with Google?


#8

Issue resolved:
I remembered I had a very restrictive robots.txt file.


#9

I need make some merchandise activation with nearby by google
This beacon plataform send me metrics for this action with google?
Need something else to make it works with the beacon?