"Couldn't confirm settings with all the beacons"


#1

Jason here, working on getting my first room done from the Indoor Location app on IOS

What happens:

  1. I walk the room and wait for each beacon to get picked up
  2. It starts to create the floor plan
  3. at about Mid way through the progress bar I get message saying “Couldn’t confirm settings with all the beacons, place you phone in the middle of the room” it gives me an option to “retry” or “start from scratch”
  4. Both options yield the same results which is the “couldnt confirm settings” pop up.

Any help would be awesome!
Thanks!


#2

I am having the same problem. Did you get this to work? Thanks!


#3

Bumping this, seems that many others are having the same issue. Is this a problem on the API-side?


#4

Let me explain first how automapping works in the Indoor Location app, to shed some more light on this issue.

The 4 beacons in each UWB dev kit are put into a mesh network in the factory. When you start auto-mapping, Indoor Location app issues an “enable UWB ranging” (i.e., the process of measuring the distances between beacons) to this mesh network, and the beacons start propagating the “enable UWB ranging” setting between themselves. While this is happening, the app goes into listening mode, to confirm that the settings got propagated to all the beacons.

The “Couldn’t confirm settings with all the beacons” error means that the app did not get that confirmation from all the beacons before a timeout was reached.

What are the possible causes for this?

  • the beacons are too far apart, and weren’t able to propagate the settings between themselves; try to stick to the recommended room size
  • there’s some problem with the mesh network; you could try removing all the beacons from mesh via cloud.estimote.com, and then form them into a brand-new mesh network
  • all the beacons used for automapping need to be on the same mesh network

There’s definitely some more work we can and want to do in the app to improve this—e.g., there’s no reason the app couldn’t automatically check if all the beacons you’re using are properly meshed together, and even mesh them for you, etc. Since the release, we’ve already improved the automapping demo a lot, and we’ll continue to do so!


#5

My issue was resolved due to a beacon being stuck in “Pending Settings”. :slight_smile:


#6

Hi, I am having a similar problem. The location app worked fine yesterday, however today it continues to show the ‘couldn’t confirm settings with all the beacons’ error.


#7

Have you tried anything from the list I mentioned above?

Based on tmcbride’s post, you could also check if any of your beacons have any pending settings in Estimote Cloud.


#8

I’ve got the same problem. The only way i’ve “fixed” it is to move the beacons in a square separated by 30ish cm… so super close. This isn’t really a fix as I can’t map the room like this, but it does confirm that the settings/mesh network is working. If i position the beacons as per the demo (around 6 strides apart) then it fails.

One thing I have noticed. If I move around the beacons when the progress bar is going, it progresses to 90% complete before sending the “Couldn’t confirm settings with all the beacons, place you phone in the middle of the room” popup.