Changed settings not working?

#1

Hey there,

I tried lowering the broadcasting power on my beacons so they would update quicker and more precise. However, it wil say that the change is pending and I need to log in and do it on the phone. This does not work. I’ve restarted everything multiple times.

All it does reset the Location to “off” and not change anything. Eventually the changes on-site also reset and just stay the same.

Maybe it’s me, but so far I’ve been running into obstacles almost exclusively using this tech (Android).

#2

Would appreciate an answer in stead of constant ignoring from the supplier.

#3

Most of Estimote Beacons don’t have any kind of internet connectivity, so if you change their settings in Estimote Cloud, these settings won’t automatically propagate to the beacons. That’s why you need to connect to the beacons with the Estimote app => at that point, the “pending settings” will get synced to the beacon.

If the settings don’t sync, that’s a bug—can you email us at contact@estimote.com with your Estimote Cloud account & the identifiers of the affected beacons, and we’ll look into it whenever somebody has a moment.

Does editing the settings directly in the Estimote app work for you?

#4

Hey heypiotr,

Whenever I use the app (as instructed) to change the settings, it turns them off. What I want to do is test if a weaker signal will increase the accuracy/updatespeed of localisation. Whenever I put this at the lowest (-40) and log into the app, it’ll sometimes show it to be off, and -40. However, when I turn it on it’ll reset to standard.
Editing directly does not work. When trying to change output from localisation, nothing gives you the option to, opposed to let’s say telemetry.

Like I originally said, I follow the instructions but it’ll just completely reset every time.

I tried updating the firmware too, to no avail. It seems this is a reoccurence of the same bug? I’ve seen post from 2015/16/17/18 about it.

#5

Thanks for some extra info. The Estimote apps don’t allow to directly change the power and intervals of the Location packet — they automatically manage these two settings based on whether you have Estimote Monitoring and/or Estimote Indoor Location (the latter is available in Location Beacons only) enabled. This would explain why you’re seeing it reset.

If you do want to manually manage the interval/power of the Location packet, you can make an appropriate “pending settings” in Estimote Cloud, then connect to the beacon in the app, not touch anything else, and disconnect. I think that should do the trick (;

In vast majority of cases, changing the transmit power doesn’t affect accuracy at all. It simply shifts the power curve, so everything becomes weaker or stronger, but the general properties of the Bluetooth signal stay the same. But a lot also depends on the environment, so let us know your findings (: It’s worth noting that this can cut both ways—we once run a test similar to yours in our test lab, and if I remember correctly, in our particular environment, lowering the signal strength decreased accuracy.

(Finally, note that -40 is extremely low power, the range should be like, centimeters to maybe a couple of meters.)

#6

Hey Piotr,

Thanks for the reply, I’m going to give it a try. Thing was, I had accuracy, but the updating went wobbly so-to-say. In stead of my avatar gliding smoothly on the screen, he would do it in smaller steps. Move-Stand-Move-Stand-Move-Stand along the path. Someone responded it had to do with the bouncing signals, hence why I’m trying to lower the output, if that make sense.

Will update you today or tomorrow!

#7

Unfortunately it still doesn’t work and just keeps resetting. On the site it says it correctly for a little bit, but through the app (even with shutting down/restarts) it just resets. Note that this is not with telemetry, it’s exclusively with localisation.

#8

Someone responded it had to do with the bouncing signals, hence why I’m trying to lower the output, if that make sense.

Yeah, I can imagine decreasing signal strength could theoretically help reduce multi-path propagation … but modeling the behavior of the radio waves is much more complex than that, so it’s hard to theorize :slight_smile:

Unfortunately it still doesn’t work and just keeps resetting. On the site it says it correctly for a little bit, but through the app (even with shutting down/restarts) it just resets. Note that this is not with telemetry, it’s exclusively with localisation.

Can you message me your Cloud account email and the identifiers of the beacons? I’ll take a look when I have a moment. (There’s should be a “message” button in a popup that shows after you click on my avatar.)