Beacons No Longer Being Found or Disappear

I recently received proximity beacons and tested on Motorola Ultra with Android 4.4.4. Communication between beacons and phone worked for about 1 week, after which the phone would (1) not find any beacons, or (2) find 0, 1, 2 or 3 beacons then lose the beacons even though phone is in proximity to all 3 (they would disappear from the Estimote app screen), and (3) using Physical Web app displays the Eddystone URL instead of displaying the Meta text and display “loading” (if app was exited and re-entered then the proper Meta text would appear).

Estimote tech support asked me to test on other phones, which I did (iOS and Droid OS) and they worked (beacons found and did not disappear). However the problem begins after a week of using the beacons, and due to my remote location I am unable to continuously test using other phones.

Verizon / Motorola is claiming the problem to be with the beacon or the apps. Estimote is claiming the problem to be with the phone.

I saw other people mentioning problem Nexus phones have with wifi interfering with Bluetooth. Turning off wifi randomly corrects the problem with the Estimote app (finds beacons about 50% of time and they do not disappear), but does correct problem with Physical Web app. Recommendations from Estimote support does not solve the problem - clearing cache, rebooting, uninstalling apps and re-installing does not solve problem.

We need functioning for a wide variety of phones that will have BOTH wifi and Bluetooth turned on, so turning wifi off is not a solution.

Does anyone have a solution? Is it problem with Android 4.4.4?