Swift 5, don´t compile


XCode was updated last night - 10.2. Now uses Swift 5. Cannot compile Estimote SDK while it´s Swift 4.2. What do I do?

We have an updated version, Proximity SDK 1.3, compiled with Swift 5. You can get it from our GitHub or from CocoaPods.

OK. Thanks. Trying to update the one I got. Will manage in the end I guess…

Let us know if you need any help (: Did you install via CocoaPods, or just manually added it to your Xcode project?


First I tried with CociaPods but didn´t manage to get the latest version 1.3 so I added it manually. Then I got problem when I uploaded the app to App Store so I went back to CocoaPods and now it seems to work fine. I guess there is a procedure to update and installed package via CocoaPods that I´m not aware of. Doesn´t matter now - it works and I´m happy again :slight_smile:

1 Like

Please update the Xamarin Binding library as well.
Xamarin apps using your proximity SDK crash when being compiled with newest Xcode.

Thanks for the reminder, @david! This should work:


Works perfectly, thank you @heypiotr .

I can’t seem to get this with CocoaPods? Only 1.2??

It’s definitely there, up to the latest 1.4.0:


Try to run pod repo update, or instead of pod install do pod install --repo-update.