LTE Beacon not charging

#1

One of My LTE beacon not working, after battery dead. I connected USB Type-C charger, but its not charging.
And I’m able to connect the LTE-Beacon for development, but I unable to run on the beacon

#2

How do you determine that the beacon is not charging? I’d say, keep it plugged in for a little while, and then try to detect it with the Estimote app, or with the Web IDE.

Also, double-check your USB charger, e.g., plug an Android smartphone into it, and see if it’s working properly.

And I’m able to connect the LTE-Beacon for development, but I unable to run on the beacon

Is this a separate beacon/problem? What do you mean by “unable to run on the beacon”, your micro-app doesn’t send any LTE events to Estimote Cloud when you’re not connected via the Web IDE? Maybe there’s no LTE-M coverage in your area:

https://www.gsma.com/iot/deployment-map/

When connected via the Web IDE, Cloud communication is routed via the web browser, not via LTE. This means that it’s entirely possible for events to work when connected to the Web IDE, but not when disconnected.

#3

Yes, its a working cable of my Pixel 3 charger and its detecting in both Estimote app and WebIDE, As it’s showing the battery percentage is 0%(charging) all time while charging the beacon.

I can connect the LTE beacon to WebIDE but its not running the microapp code for this beacon itself

Please find the screenshot but its not connected to the charger, Why its showing as charging?

image

#4

The battery percentage and the charging status refresh only during heartbeats. So your beacon is probably charged just fine, it just hasn’t refreshed its status yet (;

You can configure the regularily-scheduled heartbeat interval like this in your micro-app:

sync.setSyncPeriod(syncPeriodInSeconds);

The heartbeat also happens during sync.now(), or when beacon powers up (that’s why you see 0% - charging, that’s from this initial heartbeat), or when the battery is almost empty (a “last breath” heartbeat).

Finally, you can also force a sync by holding the side button for 10 seconds. (:

#5

I tried to run the Micro app but its executing the code in this beacon only.

I also tried for for force sync as you mentioned the side button for 10 secs, but not working

Please do check the screenshot, It has print the sys.getPublicID() but not printing any thing then it will sync.now()?

image

#6

Right, sorry, it’s both the main button + the side button for 10 seconds—I always forget about the main button (; (I think we will be changing this to just the side button in a future firmware update)

You’ll know when it worked when the beacon starts blinking the 3 side LEDs, you can release the buttons then.

1 Like
#7

By this step,
All three LEDs blink one after the other. But I checked cloud.estimote.com and WebIDE result was negative status {0% (charging)}.
Then I retried for the connecting to WebIDE and tried running the micro app, but no result. Check the screenshot

image

#8

i tried again force sync it works but still i can’t execute the microapp code in this beacon only.

#9

So the other LTE Beacon works for you? Just trying to eliminate lack of LTE-M coverage/support at your area as a factor.

Your “print” is inside a scanForAssets function, so you need to make sure this function gets called.

#10

The same micro app working on other beacon (mint) over air (like LTE-M) it connected to one of the local carrier & its works. Now I’m asking for beacon (ice), previous ice beacons works, but from this week its not working.

#11

I don’t think I still fully understand exactly what’s the problem. You have two LTE Beacon, and a micro-app that scans for iBeacon data for 3 seconds, and send the list of found data to Estimote Cloud; and repeats that every 2 minutes. Is that correct?

Both of the LTE Beacons used to “work”, but now only one (mint) “works”, and the ice does not.

Do you know what exactly isn’t working? I see you already have some prints in your code, can you add some more to try and narrow the problem down? For example, it’d be helpful to know whether the problem is that the ice beacon doesn’t detect any iBeacon data, or maybe it does but it fails to send it to Estimote Cloud, or maybe your 2-minute repeat timer doesn’t trigger? etc.

I also see that according to the most recent heartbeats, the two beacons have different micro-apps uploaded to them, so you may also want to check that.

#12

Exactly but the ice beacon was not responding in development, as I want print device id of the beacon it doesn’t work,

But the same code runs and prints for mint beacon.

#13

Still, according to the most recent heartbeats (and I checked again since my last post), your two LTE Beacons seem to be running two different apps. Please make sure that you’re running the exact same code on the two beacons. Otherwise, it looks to me like there might be a bug in your ice beacon’s code—a bug that isn’t present in the mint beacon’s code.

split this topic #14

2 posts were split to a new topic: Micro-app doesn’t sync/deploy to the LTE Beacon

#15

Just FYI, since this one topic grew to cover a lot of different, unrelated issues, I’ll be locking it now. It’s much easier for us and our LTE team to track individual topics each focused on one, specific problem/question. Please try to follow this principle in the future, it’ll make our life easier, which in turns means we can help you better/quicker.

Moved the conversation/your latest post here:

closed #16