Cant connect to beacons from Android

I am trying to connect to my Estimote beacons (Android, Samsung Galaxy S5) but it fails with message:
“Could not connect to beacon. Reason: Disconnected from beacon while trying to connect.”

Tried as well with a colleagues iPhone and he can connect to the beacons just fine.
I used to work fine from my Android phone, I dont know why it stopped working. :frowning:

Can somebody please help me with this?

Edit Btw, I just connected the phone to android debugger and this log message appears when the connecting with beacon fails:
“01-22 12:03:24.019 14587-14627/? W/EstimoteSDK: com.estimote.sdk.connection.internal.bluerock.BlueRock$1.onConnectionStateChange:104 Disconnected from GATT server (we were trying to connect, status=133)”

Error 133, our “favorite” one … (It means a general Bluetooth error.)

Can you try restarting your Bluetooth, and if that doesn’t help, the device itself? Any chance you have any other device at hand (or could borrow one for a second), and see if that one can connect? Just trying to establish whether it’s a problem with the beacon itself or not.

Hey guys, I’m having the same problem.
I just got my estimotes and I tried using it with my phone [Motorola Moto G 2nd Gen; Android 6], and I try connecting then it says “Disconnected. Tap to connect”. It does this even after I restart the device.