Cannot set to lowest power (-30dBm)

Hi I’ve just received a dev kit containing the newest batch of estimate proximity beacons (nrf52).

Using the Estimote configuration app (on Android) I am trying to set each beacon to the lowest power of -30dBm but the lowest that they will accept is -20dBm (when setting to -30dBm, it says failure in the transmit power field after syncing with the beacon).

Is there some limitation on these chips??

I’m aiming to configure these as Eddystone beacons , broadcasting at -30dBm every 100ms.

N.B. I tried configuring iBeacon and telemetry options using -30dBm and these attempts also failed.

Thanks for your help!


That’s our fault, sorry about that! We have fixes coming soon to Estimote iOS and Android apps and SDKs to address that.

Basically, the new beacons are based on a new Nordic chip, nRF52, which changed -30 dBm to -40 dBm. So in a few days, when the new apps hit the app stores, you should be able to set your beacons to -40.

That’s great news! Thank you for responding so quickly.

@heypiotr any ETA on that app update?

iOS app was updated last week, Android app will be updated this week (: