Beacons not broadcasting


I have 6 beacons (Development Kit and Development Kit with location), I had them configured with Eddystone URL some time ago and all worked OK. I have not used them for a few months and now I can’t see them broadcasting at all.
Estimote app sees them and I can connect to them but they do not broadcast.
Any idea?

Thank you

If Estimote app sees them, they must be broadcasting (:

Why do you think they’re not broadcasting?

I am using 2 different Android phones with Physical Web app and there is nothing being detected.
Also checked Chrome’s physical web feature and does not show anything.

For the URL to be visible in Physical Web / Chrome, it needs to also pass some extra checks, you can verify your URLs with this tool from Google:

Hah this is it, none of my URL pass the test.
One of the being this:

More interestingly they all worked few months ago…

Yup, Google introduced these new requirements in the meantime.

All my beacons are working now after I re-did the URLs.
Thank you Piotr for pointing me in the right direction.


1 Like