Crash in Lollipop 5.0.2

Tried my app in 2 different devices running lolliop and get a crash: “java.lang.IllegalArgumentException: This cannot be run on UI thread, starting BLE scan can be expensive”. on github you said you fixed this but i’m still getting this error. I am running version 0.4.3 and have deleted from project and readded again but still same issue.

everything works fine on on systems running previous versions of android (android >= Jellybean)

Any idea what can be wrong?

Hi, if you are changing the UI inside a thread, use runOnUiThread. I had the same problem :smile:

i got it from “the wrong angle”, i thaugt the issue was that estimote sdk ran on ui-thread, i will try your solution and get back with the result.


problem is now solved. I decided to give it another try to readd sdk in my project. i downloaded estimote sdk to a new direction instead of my default download folder and then copied jar into libs. I don’t know why but it just worked.

piggate’s solution with the old sdk might have worked aswell i’m not sure because i didn’t try it out before readd of sdk.

Thx guys.

Interesting. I know we fixed this bug in 0.4.3, maybe you had some old JAR still cached somewhere? And that’s why downloading into a new directory helped.