Cannot compile estimote SDK

This will probably sound look a noob XCode question but I’m hoping somebody might encountered this without us spending hours on it.

The iOS SDK and the sample code works fine on one dev machine, however it doesn’t compile on our other 2 macs. We get the following error (see attachment).

Anybody seen this before?

Are you on Xcode 7? Our SDK 3.7 and later is only compatible with Xcode 7, due to the nullability and generics annotations we’ve added, and which are unsupported in earlier versions of Xcode.

I tried it with Xcode 6.0 & Xcode 6.2, both gave the same error, where can I get the old version of SDK which is compatible with these Xcode?

3.6.0 is the last version with Xcode 6 support:

Out of curiosity, is there anything preventing you from updating to Xcode 7?

We are using a couple of old third party SDKs that are giving us issues with Xcode 7. We are in the process of getting those resolved so that we can upgrade. But that will take a couple of more months I think

Got it, thanks. That’s an important lesson for us.

Another, albeit a bit awkward, solution would be to strip the generics annotations from the headers. I guess a good regular expression + “find all and replace” would do it. This would allow you to use the latest (and greatest) version in Xcode 6. I don’t think you’d need to strip the nullability annotations—these were added in Xcode 6.3 AFAIR.