Android indoor-sdk values.xml app_name


I am developing an app with the Android indoor sdk version 1.0.0. I am using a tool called Appcelerator, so I have to manually include all the sdk dependencies, which I did (found in the pom file on jCenter).

One issue that I had was that the estimote sdk 1.0.12 and the indoor sdk 1.0.0 both had in their /res/values/values.xml file a tag sdk or Indoor SDK.
Appcelerator generates automatically generates a tag My App Name when the project is built (and so there is no way to change that tag name), and so during the build I get an error that a resource “app_name” has already been declared.

In older Estimote SDK’s (like 1.0.3 that I was using before) they do not have an “app_name” in their values.xml, so is it possible to take this out for future releases? Unfortunately I do not think there is a workaround in Appcelerator. I also tried manually removing that line from the aar files, but then I get runtime errors about classes not being found (EstimoteSDK class in the sdk 1.0.12, and this error from the indoor sdk (using regular sdk 1.0.3):

[ERROR] : HyperloopProxy: (main) [12226,17449] Exception thrown during invocation of method: public final, args: [com.worthingtonindustries.estimote.EstimoteApplication@3d7e2ca]
[ERROR] : HyperloopProxy: java.lang.NoClassDefFoundError: com.estimote.indoorsdk.b.a.d

I am guessing that that error is from me removing the app_name, because when I open up the jar, com.estimote.indoorsdk.b.a.d does exist.

Is there any way I can fix this issue? Or do I need to wait for an sdk release that doesn’t have the app_name string and/or try to find a workaround in Appcelerator? Any advice or insight would be greatly appreciated, even if it does not answer any questions or provide any solutions. Thanks!


We’ll handle this in the upcoming release of the Estimote SDK and the Indoor SDK.
If there will be no blocking issues, then updated versions will be available tomorrow.
Unfortunately, I’m not familiar with Appcelerator build mechanics so i’m not able to provide you with exact work-around to be used till new SDK gets released. As I understand, the Appcelerator generates Manifest file for your project - right?
If so - have you any control over the file content? I believe that adding tools:replace="android:label" to <application> tag would solve the issue.


Thanks for the reply. I think I have found out that this is actually a problem with one of the Appcelerator tools (Hyperloop), but I will post an update if I find out anything else relevant.

So first off, thanks for removing the sdk name tags from the new sdks released today. That solved my initial problem. Its awesome that you guys listen to developers needs.

Unfortunately I’m still getting the error about the class com.estimote.indoorsdk.b.a.d not being found, but I’m going to make a new post about it for clarity.