Undefined symbols for architecture arm64

I am using Cocoapods to pull the estimote sdk. I use XCode 7 (build 7A220) and targeting devices for iOS 9 and above (swift 2.0). I could compile the app without any issues. However when I try to run the app I am getting the error

Undefined symbols for architecture arm64:
  "_OBJC_CLASS_$_ESTRequestBeaconDetails", referenced from:
      type metadata accessor for ObjectiveC.ESTRequestBeaconDetails in EstimoteCloudBeaconDetails.o
ld: symbol(s) not found for architecture arm64

Am I targeting a wrong architecture ? Is there a better way to address this issue.


Can you go to Build Settings, change “Enable bitcode” to “no” and see if that helps?

Thanks for the quick resposne. My option was set to NO to begin with.

Just tried with my CocoaPods project, Xcode 7, iOS 9 target, Swift 2.0, worked here. Can you try force-cleaning your project (cmd + alt + shift + K) and/or reproducing with a fresh project? Which version of the SDK are you on? (I tried with the latest one, 3.6.0.)

Thanks for the info. Finally I could figure out what is missing. For my target, other linker flags was empty. I am not sure why it was. As suggested by you, I did create a project and used cocoapods to pull the estimote kit. This helped me to compare what is missing in my project. Thanks for your input.

1 Like