Can’t connect to a location beacon via Latest Estimote SDK’s ESTBeaconConnection

I received the estimote location beacons yesterday. I am having trouble using the latest Estimote SDK (4.13.1) to connect directly to a beacon so that I can use the ESTBeaconConnection class to get the temperature and other datas in my app. Here are the steps I am using to attempt this:
I have downloaded blank application from estimote cloud and implemented ESTBeaconConnection code like below.
Call [ESTConfig setupAppID:andAppToken:] with correct credentials from the APP that owns the beacon. Have confirmed that credentials are setup correctly by checking [ESTConfig appID],****[ESTConfig appToken],[ESTConfig isAuthorized] as well.
Used ESTBeaconConnection’s init methods to initialize the ESTBeaconConnection object (stored as instance variable in my view controller with strong reference). Have tried multiple initialization methods such as with initWithBeacon, initWithProximityUUID:major:minor, and initWithIdentifier with delegate set to self. Have tried both setting startImmediately to YES and also calling separate start connection methods.
Implemented the ESTBeaconConnectionDelegate methods beaconConnectionDidSucceed, beaconConnection:didFailWithError, and beaconConnection:didVerifyWithData.
didVerifyWithData is called but does not return an error. didFailWithError is also called. Printing the error return with didFailWithError to console yields the following message: "Error Domain=EstimoteDomain Code=402 “Device scanning timeout” UserInfo={NSLocalizedDescription=Device scanning timeout}"
I believe am doing all the required steps to actually connect to a beacon. I’m not sure where the error is.
As far as hardware goes, I am using Estimote location beacons with the latest firmware (OS4.10.1) that are all claimed under my account. The iOS version I am testing it on is iOS 10.2.1. Bluetooth is turned on for my device. I need immediate help in this case.

Connecting to beacons w/ firmware 4.x uses a new API:

ESTBeaconConnection is only for firmware < 4. Not mentioned at all in our API reference, I know—our bad, sorry for this!