"Flip to sleep mode" is not working in Location Beacon

We are trying to set the Esimote Location beacons to sleep mode with default Estimote app provided for Android & iOS and we have done the below steps to set the beacons into sleep mode.

  1. Opened settings for my beacon in Estimote cloud.
  2. Turned on flip to sleep mode and a message popped as "Some of your devices have pending settings. Connect to them with the Estimote iOS App or theEstimote Android App to apply changes."
  3. Then opened the Estimote app in Android and iOS device and connected to the beacon device and disconnected from beacon after the pending settings are updated.

But the beacons is not set to sleep mode after making the above-mentioned steps.
Kindly help us to set the beacon into sleep mode and waiting for your response.